This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 426048 - Frequent reports of BUG: soft lockup detected
Frequent reports of BUG: soft lockup detected
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.1
ia64 Linux
low Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-17 19:45 EST by Ben Webb
Modified: 2007-12-26 03:08 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-26 03:08:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Excerpt of /var/log/messages (13.53 KB, application/x-gzip)
2007-12-17 19:45 EST, Ben Webb
no flags Details

  None (edit)
Description Ben Webb 2007-12-17 19:45:07 EST
Description of problem:
We get frequent kernel bug errors in the logs on a newly-installed ia64 system
with 4 physical CPUs. These look like:
kernel: BUG: soft lockup detected on CPU#3!

See attached logfile for the full call traces. Each lockup results in the system
becoming unresponsive for a while, so this is obviously problematic for our servers.

Version-Release number of selected component (if applicable):
kernel-2.6.18-53.1.4.el5

How reproducible:
Occurs apparently randomly, every 10-15 minutes. The system is not heavily
loaded (CPU or disk IO) - in fact, it was only recently installed and is not yet
running any production services.

Steps to Reproduce:
1. Boot system normally.
  
Actual results:
System reports kernel bugs in the logs.

Expected results:
System boots and does not report kernel bugs in the logs.


Additional info:
We didn't see this problem with the original installed kernel (2.6.18-53.el5) -
the problem only started to occur once we 'yum update'd to EL5.1. Our temporary
workaround will be to downgrade the kernel - I'll follow up on this bug report
whether this fixes the problem for us.

This particular machine was previously running RHAS3 with no problems. (We
reinstalled, not upgraded, for RHEL5.)
Comment 1 Ben Webb 2007-12-17 19:45:07 EST
Created attachment 289835 [details]
Excerpt of /var/log/messages
Comment 2 Ursula Pieper 2007-12-18 17:44:09 EST
We have since added the kernel option "nosoftlockups", which resulted in
frequent spontaneous reboots of the server. 

We then downgraded to 2.6.18-53.el5. The server still has softlockups, but not
as frequent, when there is no load on the machine. 
Comment 3 Luming Yu 2007-12-24 19:58:16 EST
Any chances to try base kernel also?
Comment 4 Ben Webb 2007-12-24 22:51:00 EST
Sorry - I guess we forgot to update this. Turned out that some new memory had
recently been installed in that server, and it wasn't correctly seated. Once it
was correctly installed, the soft lockup problem disappeared. So I guess you can
close this bug report, unless you think that this is still a genuine kernel bug
in that it should have reacted differently to this misperforming hardware.
Comment 5 Luming Yu 2007-12-26 03:08:58 EST
Thanks for the update. It sounds more like firmware's responsiblity to correctly
report physical memory map...



Note You need to log in before you can comment on or make changes to this bug.