Bug 426071 - /etc/profile.d/polkit-bash-completion.sh conflicts with zsh
/etc/profile.d/polkit-bash-completion.sh conflicts with zsh
Status: CLOSED DUPLICATE of bug 418471
Product: Fedora
Classification: Fedora
Component: PolicyKit (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-18 02:32 EST by Jim Meyering
Modified: 2016-04-26 11:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-18 13:39:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Meyering 2007-12-18 02:32:00 EST
Description of problem:
with zsh as my login shell, I get this at the start of each shell:
  /etc/profile.d/polkit-bash-completion.sh:121: command not found: complete
  /etc/profile.d/polkit-bash-completion.sh:122: command not found: complete

Version-Release number of selected component (if applicable):
  $ rpm -q zsh PolicyKit 
  zsh-4.3.4-5.fc9
  PolicyKit-0.7-3.fc9

How reproducible: every time


Steps to Reproduce: run chsh, select /bin/zsh as your loging shell, and login
1.
2.
3.
  
Actual results:
  /etc/profile.d/polkit-bash-completion.sh:121: command not found: complete
  /etc/profile.d/polkit-bash-completion.sh:122: command not found: complete

Expected results: no diagnostic


Additional info:
Comment 1 David Zeuthen 2007-12-18 13:39:16 EST

*** This bug has been marked as a duplicate of 418471 ***

Note You need to log in before you can comment on or make changes to this bug.