Bug 426084 - abbreviations in VIM
abbreviations in VIM
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-18 06:06 EST by D Haley
Modified: 2008-06-24 10:32 EDT (History)
0 users

See Also:
Fixed In Version: vim-7.1.211
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-24 10:32:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description D Haley 2007-12-18 06:06:54 EST
Description of problem:
Vim is not supposed to have default abbreviations/autocorrects, but they are
present (and changing my c++ comments!).

Locale issue - Whilst editing a c++ source file in vim I noticed when I entered
the following

//Executes "set colour"

it was changed to

//Executes "set color"

Which is not quite right. Clearing the vim abbreviation list (:help abb) solves
the peoblem

Version-Release number of selected component (if applicable):
FC7

How reproducible:
always

Steps to Reproduce:
1.at a shell type "vim file.cpp"
2.type "//colour"
3.observe
  
Actual results:
//color

Expected results:
//colour

Additional info:
Vim is not supposed to have default abbreviations. see :help abb "There are no
default abbrevations in vim"
Comment 1 Karsten Hopp 2008-02-25 11:39:31 EST
please try again with vim-7.1.211 from FC7-updates. I think this was caused by a
comment plugin which has been enabled for some time until I removed it.
Comment 2 D Haley 2008-06-18 04:14:05 EDT
I have tested this in FC9, it is still there! However this problem is more major
in this case - Now it actually modifies your *source code* whilst you are
programming.


for example make a new .cpp file and save it.

then re-open it and type

#include <iostream>
#include <cstdlib>

using namespace std;

int main()
{
    const char *wtih = "weak tih";

    cout << wtih << endl;

}


then save. 

This will cause the code to change, where the wtih variable will be renamed to
with! If you are depending on external headers your code wont compile - or even
worse if there is a with and a wtih named variable, then the wrong one will be
referenced if you dont notice the as-you-type substitution.
Comment 3 Karsten Hopp 2008-06-24 10:32:40 EDT
I've checked the F-7 and F-9 sources and there's no abbreviation for p.e. colour.
The :ab command on a F-9 vim shows 'No abbreviation found'.

Please check your ~/.vimrc, ~/.vim/* and your /etc/vimrc for abbreviations. The
command ':verbose abbreviate' will tell you exactly in which file those
abbreviations have been set.

Note You need to log in before you can comment on or make changes to this bug.