Bug 426093 - 2 anaconda installations on a single system use conflicting partition labels
2 anaconda installations on a single system use conflicting partition labels
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-18 09:17 EST by Chris Pepper
Modified: 2008-06-21 12:07 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-21 12:07:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Pepper 2007-12-18 09:17:25 EST
Description of problem:
I installed RHEL5.1 on sda. Then I did another install onto sdb to test my kickstart.
anaconda used the same labels on sdb as on sda (as it does on everything), meaning that when I 
booted from sdb1 (/boot), I got the rest of the filesystems from sda, and lots of things broke.

Since anaconda doesn't check for the presence of labels before using assigning labels to partitions, it's 
impossible to do two anaconda installs onto the same system without conflicts which require manual 
resolution.

Version-Release number of selected component (if applicable):
RHEL 5.1

How reproducible:
Always.

Steps to Reproduce:
1.Install onto partitions on sda.
2.Install onto partitions on sdb.
3.Reboot. 

Actual results:
anaconda leaves GRUB pointing to sdb, but when booted /boot on sdb1 mounts the earlier filesytems 
on sda by labels.
Things break, particularly modules.

Expected results:
anaconda should not assign labels without checking to see if they're in use.

Additional info:
kickstart should have an option to use partition devices rather than labels.
Comment 1 Chris Lumens 2008-06-21 12:07:58 EDT
The next major release of RHEL will be using UUIDs for partition identification
instead of labels, so you should no longer be seeing these sorts of problems. 
If you require this fix in an update release of RHEL5, please talk to your
support representative who will raise it to us through the appropriate channels.

Note You need to log in before you can comment on or make changes to this bug.