Bug 426097 - NetworkManager-vpnc overrides /etc/resolv.conf
NetworkManager-vpnc overrides /etc/resolv.conf
Status: CLOSED DUPLICATE of bug 182011
Product: Fedora
Classification: Fedora
Component: NetworkManager-vpnc (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-18 10:06 EST by Daniel Cestari
Modified: 2007-12-18 11:24 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-18 11:24:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Cestari 2007-12-18 10:06:10 EST
Description of problem:

Whenever I connect to my VPN I need to manually edit the /etc/resolv.conf in
order to use the VPN along with normal LAN and Internet. (I need to add the
nameserver of the local router)

Version-Release number of selected component (if applicable):

NetworkManager
Version     : 0.7.0
Release     : 0.6.6.svn3109.fc8

NetworkManager-vpnc
Version     : 0.7.0
Release     : 0.6.3.svn3109.fc8

vpnc
Version     : 0.5.1
Release     : 2.fc8

How reproducible:
Using any Cisco VPN to test and NetworkManager-vpnc from fc8.

Steps to Reproduce:
1. Connect to any Cisco VPN with NetworkManager-vpnc
  
Actual results:

The /etc/resolv.conf file gets overrided and I can't access local LAN nor Internet
Expected results:


Additional info:
None
Comment 1 Denis Leroy 2007-12-18 10:20:45 EST
This is a NM enhancement request, not really a bug. As a workaround, you should
try to use the dispatcher.d feature (see comment #6 and #7 of bug 182011).


*** This bug has been marked as a duplicate of 182011 ***
Comment 2 Daniel Cestari 2007-12-18 11:07:48 EST
The problem with this is that the bug is not so much as that one because the
dispatcher script it doesn't gets called when I bring up my VPN, only when I
connect or disconnect from Wireless and so.
Comment 3 Denis Leroy 2007-12-18 11:24:48 EST
Sorry to hear the workaround doesn't work for you. still, overriding resolv.conf
is very much the expected behavior, since the DNS info comes from the vpn server
on the other side. NM could provide options to add additional custom DNs info,
and that's an enhancement requiest which is exactly what 182011 is about.


*** This bug has been marked as a duplicate of 182011 ***

Note You need to log in before you can comment on or make changes to this bug.