Bug 4261 - apmd resume failure
apmd resume failure
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: apmd (Show other bugs)
6.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-07-29 20:17 EDT by kgb
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-12-09 05:54:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kgb 1999-07-29 20:17:31 EDT
After installing Errata to Rehat 6.0 apmd-3.0beta5-8
experienced resume failures - i.e. if the system was
left suspended for a long time the system would freeze
on resume and had to be power cycled. Eeek!

Switching back to apmd-3.0beta5-7 from the CD seems
to have fixed the problem.
Comment 1 kgb 1999-07-29 20:18:59 EDT
PS system was a Gateway 9100 XL notebook
Comment 2 kgb 1999-08-11 16:10:59 EDT
More information:

The problem is NOT fixed by changing back the apmd.

Here is a better description of the problem:

If one suspends/resumes then at first there appears to be now
problem. However if one stays in the virtual console (e.g. F1)
for 1-2 minutes eventually something odd happens that locks out the
keyboard completely. If one switches back to X11 before this happens
the problem never manifests.

One can recover if one is able to telnet into the machine from
elsewhere. Simply saying 'chvt 7' in the telnet window works.

So what can happen after a resume to lock out the keyboad?
Comment 3 kgb 1999-09-02 19:58:59 EDT
Some more information:

I captured /proc/* and process listing by logging in from a networked
terminal when I experienced this problem today. I then recovered OK
by doing 'chvt 7' as root. Obviously this fix only works if one is
connected to the network!

See

ftp://ftp.aao.gov.au/pub/local/kgb/bug4621/

for my process snapshow.
Comment 4 Bernhard Rosenkraenzer 1999-11-11 10:46:59 EST
Try the apmd package from Raw Hide (3.0beta9-4), enabling the CHVT
stuff.
Comment 5 Bernhard Rosenkraenzer 1999-12-09 05:54:59 EST
As I didn't get any new feedback, I'm assuming the new package fixed it.
Comment 6 kgb 1999-12-09 06:42:59 EST
Sorry, just got round to testing it.

Couldn't find 3.0beta9-4 but found and tried 3.0beta9-6.

This does indeed fix the problem.

thanks!

Karl

Note You need to log in before you can comment on or make changes to this bug.