Bug 426101 - gtk-doc.make buggy
gtk-doc.make buggy
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gtk-doc (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-18 11:04 EST by Nils Philippsen
Modified: 2008-02-05 17:46 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-05 17:46:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nils Philippsen 2007-12-18 11:04:10 EST
Description of problem:

When running gtkdocize, gtk-doc.make gets installed which contains shell code
that is slightly buggy:

...
         if test `which gtkdoc-rebase` != ""; then \
...

This is missing quotes around the backticks and probably should redirect stderr
to /dev/null.

Version-Release number of selected component (if applicable):
gtk-doc-1.9-1.fc9

How reproducible:
Reproducible.

Steps to Reproduce:
In a project which uses gtk-doc to generate documentation (e.g. gimp):
1. Run gtk-docize
2. build
3. install
  
Actual results:

As can be seen in
http://koji.fedoraproject.org/koji/getfile?taskID=298358&name=build.log (which
is an F8 build, but gtk-doc.make was generated with gtk-doc-1.9 by upstream):

which: no gtkdoc-rebase in (/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin:/root/bin)
/bin/sh: line 11: test: !=: unary operator expected

Expected results:
- no stray messages by which that it didn't find gtkdoc-rebase
- no error messages because the backticks returned an empty string
Comment 1 Matthias Clasen 2008-02-05 17:46:42 EST
There have been multiple iterations over this upstream. I believe what we
currently have in rawhide works better.

Note You need to log in before you can comment on or make changes to this bug.