Bug 426125 - Update F6 to F8 doesn't work
Update F6 to F8 doesn't work
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-18 13:14 EST by Nigel Horne
Modified: 2008-08-08 09:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-06 17:00:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nigel Horne 2007-12-18 13:14:12 EST
Description of problem:

I get "You chose an install[ation] method that isn't supported by anaconda".
Well actually *I* didn't choose any installation method! Anyway, the program
doesn't tell me which method it doesn't like, or why it doesn't like it, or what
 installation method I should be using.


Version-Release number of selected component (if applicable):
What ever came with F8


How reproducible:
100%

Steps to Reproduce:
1. Boot of F8 DVD
2.
3.
  
Actual results:
See above


Expected results:
Should be able to upgrade


Additional info:
Comment 1 Ian Hands 2008-01-13 12:08:32 EST
The documentation http://fedoraproject.org/wiki/Anaconda/Options says that you
can fix fix your issue by specifying a installation device by passing it as an
argument to the kernel on boot.

In simpler words you can type "linux method=hd://<dev>/<path>" when booting from
the cd (and prompted for user input).

The <dev>/<path> part will most likely be /dev/sr<number> (so the option would
look like method=hd:///dev/sr1). You are most likely trying to access /dev/sr0
by default and require /dev/sr1. The sr<num> means a scsi read-only device (all
ide devices are now using scsi emulation) and the number is the order (starting
at 0) of the device reported to the kernel from the bios.

Hope this resolves you issue.
Comment 2 Ian Hands 2008-01-13 12:20:14 EST
Excuse me I seem to have made my post in the wrong window.... My post above is
intended for another bug.

Sorry,
-Ian
Comment 3 Chris Lumens 2008-01-24 11:15:42 EST
What sort of messages are you seeing on tty3 (press ctrl-alt-f3)?
Comment 4 Andy Lindeberg 2008-08-06 17:00:52 EDT
We do not support upgrading directly from F6 to F8. If you want to upgrade, we highly recommend first upgrading to F7 and then to F8.
Comment 5 Nigel Horne 2008-08-07 12:53:14 EDT
If you don't support it then why did your software attempt it without giving an error message.

Not giving an error message and instead attempting the upgrade gives the user the impression that you *do* support it.
Comment 6 Andy Lindeberg 2008-08-08 09:34:46 EDT
Unless I'm mistaken, the error message you've reported is what you get when trying to upgrade... Seems like a pretty clear "don't do this" to me.

This is worth checking into though - I'm not sure there's any reason why we can't turn off the upgrade option if we detect any installation other than the previous one. We even seem to allow "upgrading" from a later version to an earlier one, though attempting this crashes the installer.

Note You need to log in before you can comment on or make changes to this bug.