Bug 426150 - DHCP does not work in update kernel using 3945 wireless
DHCP does not work in update kernel using 3945 wireless
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-18 15:15 EST by Skippy
Modified: 2007-12-23 08:45 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.6.23.9-85.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-23 08:45:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Skippy 2007-12-18 15:15:02 EST
Description of problem:

I have an ASUS F3SC running Fedora 8 x86_64. This laptop has the "Santa Rosa"
chipset. It comes with an onboard "Intel Corporation PRO/Wireless 3945ABG
Network Connection (rev 02)" wireless adapter. I am using the iwlwifi driver
that comes with Fedora 8.

I am attaching to a Netgear wireless access point dooberry, using 128 bit WEP.

In Fedora 8 kernel version kernel-2.6.23.8-63.fc8 DHCP does not work with this
wireless card- however it does work with kernel-2.6.23.1-49.fc8. Something has
gone wrong between these two versions.

How to reproduce:

Boot kernel of your choice, without starting network adaptors.


iwconfig wlan0 essid "whatever"
iwconfig wlan0 key "whatever"
iwconfig wlan0 mode managed
iwconfig wlan0 ap auto
dhclient wlan0

With the newer kernel, you never get an IP. If you set an ip address manually,
you have no problems.
Comment 1 John W. Linville 2007-12-18 17:52:10 EST
Please attach the contents of /var/log/messages after running dhclient.

Is that the exact order of commands you issued above?  FWIW, it should be 
something more like this:

iwconfig wlan0 mode managed   # This is probably not necessary
iwconfig wlan0 ap auto        # This is probably not necessary either
iwconfig wlan0 key "whatever" # Set the key before setting the SSID
iwconfig wlan0 essid "whatever"
dhclient wlan0

Does that work any better?  Any reason you aren't using NetworkManager or 
system-config-network?
Comment 2 Skippy 2007-12-23 08:45:41 EST
I am using ifup, system-config-network and so on. My real problem is that my
wireless card didn't come up using ifup. I was trying to give you a concrete
repeatable bug you could solve.

Anyway, it doesn't matter now, since DHCP does work in 2.6.23.9-85.fc8. I have
now got a similar but different problem which I am about to report in another
bug, which I'd like to draw your attention to.

Note You need to log in before you can comment on or make changes to this bug.