Bug 426176 - Orphaned npviewer.bin processes
Orphaned npviewer.bin processes
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nspluginwrapper (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-18 18:59 EST by Braden McDaniel
Modified: 2008-01-15 17:54 EST (History)
3 users (show)

See Also:
Fixed In Version: 0.9.91.5-16.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-15 17:54:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
okay, here is the patch (1.03 KB, patch)
2008-01-14 08:18 EST, Martin Stransky
no flags Details | Diff

  None (edit)
Description Braden McDaniel 2007-12-18 18:59:51 EST
Description of problem:
I'm getting orphaned npviewer.bin processes; probably resulting from Epiphany
crashes.

Version-Release number of selected component (if applicable):
0.9.91.5-13.fc8
Comment 1 Martin Stransky 2007-12-19 03:42:02 EST
I've already created a patch for this issue and it's included in 0.9.91.5-13.fc8
 so it should not happen. Can you please try to reproduce it?
Comment 2 Braden McDaniel 2007-12-19 03:58:06 EST
I can reproduce this by killing the epiphany process; after doing so, the
npviewer.bin process is still around.
Comment 3 Jonathan Wakely 2008-01-05 13:56:37 EST
I see orphaned npviewer.bin processes after firefox crashes, with
nspluginwrapper-0.9.91.5-14.fc8

The orphaned process uses a *lot* of CPU, here is a grab from top:

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
 2982 redi      20   0 97396  30m 9888 R 44.5  3.0 104:45.18 npviewer.bin
 3042 redi      20   0  731m 142m  23m S  2.3 14.2   7:47.13 firefox-bin
 3113 redi      20   0 94504  18m 9864 S  2.3  1.8  15:45.68 npviewer.bin

Note that the first npviewer.bin has a lower PID than firefox, this is because
my first firefox session crashed and I restarted it.  The 44.5% CPU figure isn't
a random spike either - it sits there near 50% most of the time.

This shows the first process has a PPID of 1:

$ ps -efw  | fgrep npviewer
redi      2982     1 43 14:40 ?        01:45:04
/usr/lib/nspluginwrapper/npviewer.bin --plugin
/usr/lib/mozilla/plugins/libflashplayer.so --connection
/org/wrapper/NSPlugins/libflashplayer.so/2581-1
redi      3113  3042  6 14:44 ?        00:15:46
/usr/lib/nspluginwrapper/npviewer.bin --plugin
/usr/lib/mozilla/plugins/libflashplayer.so --connection
/org/wrapper/NSPlugins/libflashplayer.so/3042-1

Comment 4 Jonathan Wakely 2008-01-12 18:42:31 EST
Attaching a debugger to the orphan and halting it shows either:

0  0xffffe405 in __kernel_vsyscall ()
#1  0x0035cac3 in poll () from /lib/libc.so.6
#2  0x0046b583 in ?? () from /lib/libglib-2.0.so.0
#3  0x0046b8f9 in g_main_loop_run () from /lib/libglib-2.0.so.0
#4  0x070f13ea in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#5  0x08050342 in main (argc=<value optimized out>, argv=0xffa442c4)
    at ../src/npw-viewer.c:3222

or

#0  0xf77e9ab3 in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so
#1  0xf77eb6e7 in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so
#2  0xf77ec012 in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so
#3  0xf7a9fcdb in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so
#4  0xf7aa388a in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so
#5  0xf7bc0162 in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so
#6  0xf7bc4738 in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so
#7  0xf7bc4915 in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so
#8  0xf776d55d in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so
#9  0xf7bcf8df in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so
#10 0xf784963b in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so
#11 0xf776d01e in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so
#12 0x004688c6 in ?? () from /lib/libglib-2.0.so.0
#13 0x0046810c in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#14 0x0046b54f in ?? () from /lib/libglib-2.0.so.0
#15 0x0046b8f9 in g_main_loop_run () from /lib/libglib-2.0.so.0
#16 0x070f13ea in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#17 0x08050342 in main (argc=<value optimized out>, argv=0xffa442c4)
    at ../src/npw-viewer.c:3222

I'm using the flash-plugin-9.0.115.0-release.i386 RPM from Abode, and the latest
wrapper RPMs:
nspluginwrapper-0.9.91.5-15.fc8.x86_64
nspluginwrapper-0.9.91.5-15.fc8.i386

Comment 5 Martin Stransky 2008-01-14 08:18:34 EST
Created attachment 291581 [details]
okay, here is the patch
Comment 6 Martin Stransky 2008-01-14 08:28:22 EST
added to nspluginwrapper-0.9.91.5-16.fc8
Comment 7 Fedora Update System 2008-01-15 17:54:09 EST
nspluginwrapper-0.9.91.5-16.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.