Bug 426177 - knetworkmanager crippled in Fedora 8
knetworkmanager crippled in Fedora 8
Status: CLOSED DUPLICATE of bug 298991
Product: Fedora
Classification: Fedora
Component: knetworkmanager (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-18 19:33 EST by Philippe Rigault
Modified: 2008-01-05 17:53 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-18 19:59:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philippe Rigault 2007-12-18 19:33:54 EST
Description of problem:

knetworkmanager, a very useful KDE app (especially for laptops) which has been 
present in past Fedora releases, has been replaced in Fedora 8 by a gnome 
program with _less_ functionality that _pretends_ to be knetworkmanager.
knetworkmanager used to work well in Fedora 7, so this is a regression.

Version-Release number of selected component (if applicable):

knetworkmanager-0.2-0.7.fc8

How reproducible: 100%


Steps to Reproduce:
1. Log in KDE
2. Start knetworkmanager
3. Expect to see knetworkmanager
  
Actual results: some ugly gnome-ish looking applet appears that is not 
knetworkmanager, and is not any more integrated with the desktop's password 
manager (kwallet).

Expected results:

'knetworkmanager' starts ... knetworkmanager, the one and only, KDE-looking 
and integrated with kwallet.

Additional info:

Fedora8 knetworkmanager is a totally different thing from knetworkmanager:

$ rpm -ql knetworkmanager
/etc/kde/env/gnome-keyring-daemon-start.sh
/etc/kde/shutdown/gnome-keyring-daemon-stop.sh
/usr/bin/knetworkmanager
/usr/share/applications/fedora-knetworkmanager.desktop

$ more /usr/bin/knetworkmanager
#!/bin/sh

exec /usr/bin/nm-applet

Yuck, this is very bad. It is a blatant case of program naming abuse and lying 
to the user: the knetworkmanager application has been _replaced_ by something 
else that claims to be the original application. This thing should be 
called 'gnome-networkmanager-applet' or 'fedora-networkmanager-applet', but in 
no way knetworkmanager.

Please restore knetworkmanager in Fedora and name this horror something else.
Fedora KDE users deserve to have a true KDE.
Comment 1 Rex Dieter 2007-12-18 19:59:01 EST
Yep, unfortunately, knetworkmanager doesn't yet work with NetworkManager >= 0.7
(as is included in F8, see bug #298991).

The best option we came up with (to handle upgrade cases primarily), was to
introduce a place-holder until when/if the situation improved.

Rest assured, we wouldn't be in this situation if there were any (better)
alternative.

*** This bug has been marked as a duplicate of 298991 ***

Note You need to log in before you can comment on or make changes to this bug.