This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 426180 - mono build needs to require libunwind-devel on ia64
mono build needs to require libunwind-devel on ia64
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: mono (Show other bugs)
rawhide
ia64 Linux
high Severity high
: ---
: ---
Assigned To: Alexander Larsson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2007-12-18 20:12 EST by Doug Chapman
Modified: 2007-12-19 09:18 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-19 05:34:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2007-12-18 20:12:55 EST
Description of problem:
The mono package fails to build on ia64 under mock.  The reason is libunwind has
now been split into libunwind and libunwind-devel.  mono needs to require both
for building so mock knows to pull them in.

This is just for ia64 so it is a matter of updating the spec file with:

%ifarch ia64
BuildRequires:  libunwind
BuildRequires:  libunwind-devel
%endif


thanks,

- Doug Chapman


Version-Release number of selected component (if applicable):
mono-1.2.5.2-2.fc9

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Paul F. Johnson 2007-12-19 05:30:32 EST
Unless the devel repo I'm using has not been updated for a long time, but the
last version of libunwind for x86_64 is an fc7 build.

I don't have libunwind installed and it's yet to fail to build.

Are you sure on this?
Comment 2 Doug Chapman 2007-12-19 09:18:40 EST
It works OK on x86_64 becuase mono does not require libunwind at all on that
platform.  It is required however for ia64.  Note in the current spec file there is:

%ifarch ia64
BuildRequires:  libunwind
%endif

we need to change this to

%ifarch ia64
BuildRequires:  libunwind
BuildRequires:  libunwind-devel
%endif

thanks,

- Doug

Note You need to log in before you can comment on or make changes to this bug.