Bug 426183 - python-sqlite2 has unpackaged files
python-sqlite2 has unpackaged files
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: python-sqlite2 (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Dawid Gajownik
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2007-12-18 21:28 EST by Doug Chapman
Modified: 2008-03-05 17:35 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-05 17:35:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2007-12-18 21:28:57 EST
Description of problem:
We are seeing this on ia64 since we still are building a lot of packages for the
first time.  I expect all other arches will see this as well when they rebuild.

The python-sqlite2 package fails to build due to:

RPM build errors:
    Installed (but unpackaged) file(s) found:
   /usr/lib/python2.5/site-packages/pysqlite-2.3.3-py2.5.egg-info


The package has not been built since F7, my guess is rpmbuild did not have the
check for installed but unpackaged files at that point.

The fix is to either include this file in the %files section of the spec file
(if we want to package it), remove the file at the end of the %install stage, or
modify the makefiles to not install it in the first place.


Version-Release number of selected component (if applicable):
python-sqlite2-2.3.3-1

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Doug Chapman 2008-03-05 17:35:06 EST
I see this has now been fixed.

thanks,

- Doug

Note You need to log in before you can comment on or make changes to this bug.