Bug 426189 - Conga attempts to free a null pointer
Conga attempts to free a null pointer
Status: CLOSED DUPLICATE of bug 441376
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: conga (Show other bugs)
4
All Linux
low Severity low
: ---
: ---
Assigned To: Ryan McCabe
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-19 00:09 EST by Norm Murray
Modified: 2009-04-16 16:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 15:58:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wade Mealing 2007-12-19 00:09:23 EST
Description of problem:

The ricci code attempts to free a null pointer in Monitor.ccp.  This is fixed in
CVS, but I can't find the bugzilla for where this is fixed, but the BZ is
required for the hotfix process. 

Version-Release number of selected component (if applicable):

ricci-0.9.1-8

How reproducible:

When you follow the steps, pretty much every time.

Steps to Reproduce:
1. Somehow break the connection to the cman cluster, (iptables, router
filtering, etc)
2. Connect to the web interface
3. Attempt an action.
  
Actual results:

modclusterd crashes.

Expected results:

Modclusterd not to crash

Additional info:


It is fixed in:

http://sources.redhat.com/cgi-bin/cvsweb.cgi/conga/ricci/modules/cluster/clumon/src/daemon/Monitor.cpp.diff?r1=1.13.2.2&r2=1.13.2.3&cvsroot=cluster&f=h
Comment 1 RHEL Product and Program Management 2007-12-19 00:15:26 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Ryan McCabe 2008-04-07 15:58:47 EDT

*** This bug has been marked as a duplicate of 441376 ***

Note You need to log in before you can comment on or make changes to this bug.