Bug 426204 - Suppress bogus message in opcontrol when backtrace isn't supported
Suppress bogus message in opcontrol when backtrace isn't supported
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: oprofile (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: William Cohen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-19 05:18 EST by Markus Armbruster
Modified: 2013-03-11 13:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-11 13:40:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Markus Armbruster 2007-12-19 05:18:01 EST
Description of problem:
When oprofile doesn't support struct oprofile_operations method backtrace,
opcontrol --start-daemon prints a bogus error message.

This happens with Xenoprof (bug 401361).  Since that's unlikely to be fixed in
5.2, opcontrol needs to be fixed instead.

How reproducible:
Always.

Steps to Reproduce:
1. In a Xen dom0: opcontrol --start-daemon --no-vmlinux --xen=none
  
Actual results:
opcontrol prints:
/usr/bin/opcontrol: line 1082: echo: write error: Invalid argument
Using default event: CPU_CLK_UNHALTED:100000:0:1:1
Using 2.6+ OProfile kernel interface.
Using log file /var/lib/oprofile/oprofiled.log
Daemon started.

Expected results:
No write error.
Comment 1 William Cohen 2009-10-27 10:04:41 EDT
The problem is the xen oprofile kernel interface doesn't have a proper functioning /dev/oprofile/backtrace_depth. Oprofile is trying to initialize it and fails.
Comment 4 Frank Ch. Eigler 2013-03-11 13:40:10 EDT
It's a minor annoyance not worth fixing.

Note You need to log in before you can comment on or make changes to this bug.