Bug 426217 - Please rebuild perl-Archive-Zip for EPEL 4
Please rebuild perl-Archive-Zip for EPEL 4
Product: Fedora EPEL
Classification: Fedora
Component: perl-Archive-Zip (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
Depends On:
Blocks: 249079
  Show dependency treegraph
Reported: 2007-12-19 07:32 EST by Robert Scheck
Modified: 2007-12-30 18:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-12-30 18:10:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2007-12-19 07:32:43 EST
Description of problem:
Please rebuild perl-Archive-Zip for EPEL 4.

Version-Release number of selected component (if applicable):

How reproducible:
No perl-Archive-Zip in EPEL 4

Expected results:
Package perl-Archive-Zip in EPEL 4, because it's an amavisd-new dependency.

Additional info:
Please let me know, when you're not interested in maintaining the package 
Mockbuild in EPEL 4 succeded for me and looks fine, too (that even means, the 
package is working for me on an RHEL 4 system). Taking the package from EPEL5
(or was it CentOS 5?) and rebuilding just worked for me:

Wrote: /builddir/build/RPMS/perl-Archive-Zip-1.16-1.el4.noarch.rpm
Comment 1 Steven Pritchard 2007-12-19 11:51:00 EST
This is a *fun* circular dependency.

perl-Archive-Zip requires perl-Compress-Zlib, which requires
perl-IO-Compress-Base, which wants perl-Test-Pod for a build dependency (not
strictly necessary, but still...), which requires perl-Test-Builder-Tester,
which requires perl-Module-Build, which requires perl-Archive-Tar, which
requires perl-IO-Zlib, which requires perl-Compress-Zlib.

If we drop the Test::Pod dependency in perl-IO-Compress-Base, we should be able
to get everything else built.
Comment 2 Robert Scheck 2007-12-19 12:37:25 EST
Steven - stop! Please just build perl-Archive-Zip-1.16-1 (taken from EPEL 5) 
first. Otherwise EPEL 4 would ship newer software than EPEL 5...
Comment 3 Robert Scheck 2007-12-30 18:10:55 EST
perl-Archive-Zip-1.16- is available in epel-testing - if you would like 
to upgrade to something newer, it's up to you. But keep in mind, that then EPEL 
5 also has to be updated.

Note You need to log in before you can comment on or make changes to this bug.