Bug 426233 - WPA fails.
WPA fails.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-19 08:33 EST by David Woodhouse
Modified: 2008-09-05 12:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-05 12:59:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
wpa_supplicant output (92.56 KB, text/plain)
2007-12-19 08:34 EST, David Woodhouse
no flags Details

  None (edit)
Description David Woodhouse 2007-12-19 08:33:12 EST
Although wpa_supplicant works fine if the passphrase is set up in
wpa_supplicant.conf, I cannot associated with my WPA access point by using
NetworkManager.

This works, when added to wpa_supplicant.conf:
network={
        scan_ssid=1
        ssid="OLPCOFW"
        key_mgmt=WPA-PSK
        psk="fishfish"
}

Entering the same information into nm-applet's dialog box seems to fail.
Comment 1 David Woodhouse 2007-12-19 08:34:31 EST
Created attachment 290018 [details]
wpa_supplicant output
Comment 2 Dan Williams 2007-12-24 18:19:40 EST
I'm thinking there's a BE bug in the passphrase hashing again; I tried and
failed to find an available PPC Mac last week.  We should verify that the hex
key as wpa_supplicant see it after NM sets it is what it should be.  Feel
inclined to compile an SRPM of wpa_supplicant for me to validate this hypothesis?
Comment 3 Dan Williams 2007-12-24 18:40:37 EST
http://people.redhat.com/dcbw/wpa_supplicant-0.5.7-20.1.fc8.src.rpm

Match the Hex PSK that's hexdumped prefixed SET_NETWORK that looks like:

SET_NETWORK(byte array) key psk
    value  - hexdump(len=32): ff ff ff ff ff ff ff ...

with the output of:

/usr/sbin/wpa_passphrase <ssid> <passphrase>

If they're different, there's an NM problem.
Comment 4 David Woodhouse 2007-12-25 03:02:16 EST
ssid is 'OLPCOFW' passphrase is 'fishfish'. Will play later; there'll be trouble
if do too much today :)
Comment 5 David Woodhouse 2007-12-26 04:11:06 EST
$ /usr/sbin/wpa_passphrase OLPCOFW fishfish
network={
        ssid="OLPCOFW"
        #psk="fishfish"
        psk=c0f3089a12a0e61b6f4359206982e15c49c0caade56376b35dc80e57c54715ce
}

vs.

SET_NETWORK(byte array) key psk
    value  - hexdump(len=32): f3 de 39 63 d1 af 73 dd 9e b3 ed df 69 78 cb 65 9d
25 af f9 ac 8d ac c3 1e 85 70 87 ec 85 e6 bc
Comment 6 David Woodhouse 2007-12-26 04:39:01 EST
If I define WORDS_BIGENDIAN in nm-applet-0.7.0/src/wireless-security/sha1.c then
it works, but only after killing wpa_supplicant.
Comment 7 Dan Williams 2007-12-27 03:27:35 EST
again.  fix is actually to #include "config.h" at the top of sha1.c.

Committed to upstream network-manager-applet SVN, r414.
Comment 8 Bug Zapper 2008-05-14 00:13:02 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Gianluca Varisco 2008-09-05 05:29:34 EDT
Dan, could we mark this ticket as solved (CURRENTRELEASE)?
Comment 10 Dan Williams 2008-09-05 12:59:40 EDT
haha, yeah

Note You need to log in before you can comment on or make changes to this bug.