This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 426243 - anaconda does not honor ksdevice=bootif fully
anaconda does not honor ksdevice=bootif fully
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-19 10:17 EST by Jan Christiaan van Winkel
Modified: 2008-08-05 16:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-05 16:41:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
lspci -v output of system to be kickstarted (10.05 KB, text/plain)
2007-12-19 10:17 EST, Jan Christiaan van Winkel
no flags Details
output of ifconfig -a on system (1.62 KB, text/plain)
2007-12-19 10:19 EST, Jan Christiaan van Winkel
no flags Details
relevant part of pxe config file (622 bytes, text/plain)
2007-12-19 10:20 EST, Jan Christiaan van Winkel
no flags Details
a relevant kickstartfile is here. (842 bytes, application/octet-stream)
2008-05-06 02:14 EDT, Jan Christiaan van Winkel
no flags Details

  None (edit)
Description Jan Christiaan van Winkel 2007-12-19 10:17:12 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
allways

Steps to Reproduce:
1. have a machine where PXE boot is done from eth1, eth0 is disconnected
2. PXE boot the machine for NFS kickstart
3. 

Actual results:
After the kernel hass been downloaded from eth1 (and initrd), anaconda tries to
get a DHCP address for the non-connected eth0.  If you plug in a cable to eth0
just to get it an address, anaconda continues to kickstart from eth1 (as
expected using ksdevice=bootif and IPADDRESS 2 in the pxe config file

Expected results:
eth0 should be left alone, eth1 should have been used

Additional info:
this is a desktopmachine with an Intel Pro1000 interface on board with PXE
capabilities.  An additional (8139too) ethernet interface is installed in one of
the PCI interfaces.  The BIOS will use the intel card to boot, but then the
kernel sees the intel card as eth1, and the realtek card as eth0
Comment 1 Jan Christiaan van Winkel 2007-12-19 10:17:12 EST
Created attachment 290027 [details]
lspci -v output of system to be kickstarted
Comment 2 Jan Christiaan van Winkel 2007-12-19 10:19:06 EST
Created attachment 290028 [details]
output of ifconfig -a on system
Comment 3 Jan Christiaan van Winkel 2007-12-19 10:20:17 EST
Created attachment 290029 [details]
relevant part of pxe config file
Comment 4 David Cantrell 2008-04-23 18:35:33 EDT
What does your kickstart file look like?

If you have network commands for eth0 and eth1, then anaconda will try to bring up all of those 
interfaces as specified.  When doing a kickstart install, we bring up all interfaces listed in the kickstart file 
because the user may have something in %pre or %post that depends on the other interfaces being up.
Comment 5 Jan Christiaan van Winkel 2008-05-06 02:14:21 EDT
Created attachment 304601 [details]
a relevant kickstartfile is here.
Comment 6 David Cantrell 2008-08-05 16:41:04 EDT
What you are describing is expected.  You have two network lines in your kickstart file, so anaconda tries to bring up both interfaces during installation.  Your description also states that ksdevice=BOOTIF is working, it's just that eth0 is brought up anyway...which is because you have two network lines in your kickstart configuration file.

Note You need to log in before you can comment on or make changes to this bug.