This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 426257 - gcc_intrin.h fails in userspace builds on ia64
gcc_intrin.h fails in userspace builds on ia64
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
ia64 Linux
high Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2007-12-19 11:49 EST by Doug Chapman
Modified: 2008-02-13 22:19 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-13 22:19:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix userspace (559 bytes, patch)
2008-01-16 15:01 EST, Doug Chapman
no flags Details | Diff

  None (edit)
Description Doug Chapman 2007-12-19 11:49:20 EST
Description of problem:
Some packages include <linux/ipv6.h> which eventually includes
<asm/gcc_intrin.h> which fails to build on ia64 outside of the kernel.  There
are likely other paths where gcc_intrin.h is included as well but this is the
one I am running into (when building the dhcpv6 package on ia64).

The failure can most easily be reporoduced with a 1 liner c program that does
nothing but:

#include <linux/ipv6.h>

when compiling this it fails with:

# cc foo.c
In file included from /usr/include/asm/intrinsics.h:18,
                 from /usr/include/asm/byteorder.h:10,
                 from /usr/include/linux/ipv6.h:5,
                 from foo.c:3:
/usr/include/asm/gcc_intrin.h:26: error: expected ‘,’ or ‘;’ before
‘__attribute_used__’

The problem is __attribute_used__ is defined in linux/compiler-gcc3.h and
compiler-gcc4.h neither of which are packaged with the userspace kernel-headers
package.

I did some digging and it appears this patch was included in -mm:

http://www.kernel.org/pub/linux/kernel/people/akpm/patches/2.6/2.6.18-rc1/2.6.18-rc1-mm2/broken-out/git-hdrcleanup-vs-git-klibc-on-ia64.patch

I am guessing this was never pulled into the upstream kernel because technically
the kernel is not broken since it has all the needed .h files and
__attribute_used__ is defined.  It is just when we pull those out of the
usperspace that the problem is introduced.




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Doug Chapman 2008-01-16 15:01:51 EST
Created attachment 291880 [details]
patch to fix userspace

This patch fixes the issue of not being able to build the dhcpv6 package.  Can
we see about getting this into fedora?	When dhcpv6 fails to build that can
also cause anaconda to fail (and anaconda is important!).

I will also see about getting this committed upstream but not sure if there was
a reason for not taking it a while back as I did find it is in -mm but not in
linus's tree.


thanks,

- Doug
Comment 2 Doug Chapman 2008-02-13 22:19:19 EST
This has been fixed upstream and that fix was pulled into fedora in a recent
kernel pull.  Closing this BZ.

Note You need to log in before you can comment on or make changes to this bug.