Bug 426325 - Compressed emacs elisp files break emacs conventions and certain emacs functions
Compressed emacs elisp files break emacs conventions and certain emacs functions
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Chip Coldwell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-19 20:48 EST by Need Real Name
Modified: 2008-01-15 14:16 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-15 14:16:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2007-12-19 20:48:37 EST
Description of problem:
For some reason the elisp files in emacs-el are now all stored compresses.
This breaks functions such as find-file (which itself is part of emacs-el) and
in general makes it a lot harder to use. More generally, having compressed and
less accessible source kind of goes against the whole extensible philosophy of
emacs.

The other fedora elisp packages (e.g., bbdb-el, vm-el) do not store their elisp
function compressed.

I can't believe that in this day of true code bloat that we need to scrimp so
much on emacs lisp packages (which are optional installs anyway). After all, I
started using emacs back in the early 1980's when disk space was almost 100,000
times more expensive per byte.
Comment 1 Tom Tromey 2008-01-12 13:50:23 EST
FWIW -- this is an upstream decision.
Also, find-file and find-function are smart enough to auto-uncompress the
.el.gz when opening it.  Does this not work for you?
Comment 2 Need Real Name 2008-01-15 14:15:50 EST
I think the problem was that I didn't have auto-compression-mode set correctly.
At some point the default changed and I was just toggling it in my .emacs file
rather than doing (auto-compression-mode 1) to make sure it is on no matter what.

So, fixing that solved my problems and I will bow to the upstream decision...

Note You need to log in before you can comment on or make changes to this bug.