Bug 426331 - thunderbird -compose : wrong behaviour
thunderbird -compose : wrong behaviour
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-20 00:51 EST by Jost Diederichs
Modified: 2008-03-03 09:25 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-03 09:25:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jost Diederichs 2007-12-20 00:51:32 EST
Description of problem:
this problem relates to the redhat launch script of thunderbird:
/usr/bin/thunderbird

when issuing the command 
</usr/bin/thunderbird -compose
"to=mail@foo.net,subject=test&bcc=,body=test,attachment='bla1,bla2'">
everything works as expected if thunderbird is not already running.

However, when thunderbird is already running, the compose window will be
incorrectly filled out.

Version-Release number of selected component (if applicable):
thunderbird-2.0.0.9

How reproducible:
always

Additional info:
the following patch will fix this:
--------------
--- /usr/bin/thunderbird.org    2007-12-19 21:08:42.000000000 -0800
+++ /usr/bin/thunderbird        2007-12-19 21:17:11.000000000 -0800
@@ -79,12 +79,6 @@
     -compose)
         shift
-        if [ "${ALREADY_RUNNING}" -eq "1" ]; then
-            # remove 'mailto:' prefix
-            ARGS="`echo $@ | sed 's/^mailto://'`"
-            exec $MOZ_CLIENT_PROGRAM "mailto($ARGS)"
-        else
-            rm_shit
-            exec $MOZ_PROGRAM $MOZARGS -compose "$@"
-        fi
+        rm_shit
+        exec $MOZ_PROGRAM $MOZARGS -compose "$@"
         ;;
------------------
I have tested this patch with picasa and nautilus and it fixed my problems. 
The patch should work universally because there is no need to prevent the
creation of a new window when the compose window is a new window in any case. 

I haven't dug in deep, but I suspect that the /usr/bin/thunderbird script
contains a few legacy things. I wonder if a simple link to
/usr/lib(64)/thunderbird/thunderbird wouldn't do the job just fine without the
/usr/bin/thunderbird script?
Comment 1 Dawid Lorenz 2008-01-30 15:30:52 EST
I've ran into the same issue, when I tried to solve nautilus-sendto thunderbird
plugin bug, which was never adding attachments and/or recipients properly.
Fortunately solution given by Jost worked for me, however it needs fixing in
next thunderbird release for Fedora.

Btw, that problem does not seem to occur in Ubuntu - I've checked with my
workmate, an Ubuntu user.
Comment 2 Martin Stransky 2008-02-28 07:41:07 EST
Taking the bug.
Comment 3 Martin Stransky 2008-03-03 09:25:08 EST
Fixed in thunderbird-2.0.0.12-2.fc9.

Note You need to log in before you can comment on or make changes to this bug.