Bug 426369 - Incorrect get_mempolicy prototype
Incorrect get_mempolicy prototype
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: numactl (Show other bugs)
5.3
All Linux
low Severity low
: rc
: ---
Assigned To: Neil Horman
:
Depends On: 418551
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-20 10:14 EST by Neil Horman
Modified: 2009-01-20 16:05 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:05:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neil Horman 2007-12-20 10:14:25 EST
+++ This bug was initially created as a clone of Bug #418551 +++

Description of problem:
The <numaif.h> header contains:

extern long get_mempolicy(int *policy, 
                          const unsigned long *nmask, unsigned long maxnode,
                          void *addr, int flags);

But the nmask pointer points to writable memory.  This problem is not noticed by
the compiler when compiling the package since this is a system call.  But it
might lead to bad problems when using the interface since the compiler can
assume the memory is not changed.



Version-Release number of selected component (if applicable):
0.9.8-4

How reproducible:
always

Steps to Reproduce:
1.look at /usr/include/numaif.h
2.
3.
  
Actual results:
above prototype

Expected results:
const removed:
extern long get_mempolicy(int *policy, 
                          unsigned long *nmask, unsigned long maxnode,
                          void *addr, int flags);

Additional info:
This must also be fixed in RHEL versions.  Without this change incorrect code
might silently be generated.
Comment 1 RHEL Product and Program Management 2007-12-20 13:25:23 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 RHEL Product and Program Management 2008-01-02 09:44:58 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release.  This request will
be reviewed for a future Red Hat Enterprise Linux release.
Comment 3 Neil Horman 2008-01-04 10:01:19 EST
checked into my pre-53 branch, I'llmerge to mainline, once I have acks on this
Comment 4 RHEL Product and Program Management 2008-06-02 16:25:51 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Neil Horman 2008-06-03 14:21:55 EDT
committed to -5.el5
Comment 10 errata-xmlrpc 2009-01-20 16:05:59 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0139.html

Note You need to log in before you can comment on or make changes to this bug.