Bug 426396 - No dual screen on a 24 inch white iMac
No dual screen on a 24 inch white iMac
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-20 14:30 EST by Andreas Tunek
Modified: 2008-06-05 08:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-04 07:58:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.cong with cable plugged in. (967 bytes, application/octet-stream)
2007-12-21 06:39 EST, Andreas Tunek
no flags Details
Log 1 (46.01 KB, text/plain)
2007-12-21 06:40 EST, Andreas Tunek
no flags Details
log 2 (46.12 KB, text/plain)
2007-12-21 06:41 EST, Andreas Tunek
no flags Details
Don't really know what this is.... (1.04 KB, text/plain)
2007-12-21 06:41 EST, Andreas Tunek
no flags Details
xorg.conf + log (32.96 KB, application/octet-stream)
2008-03-30 12:10 EDT, Andreas Tunek
no flags Details

  None (edit)
Description Andreas Tunek 2007-12-20 14:30:34 EST
Description of problem:
I have a 24 inch white iMac with a nVidea 7300. Everything works fine, but when
I plug in an external monitor through the miniDVI port I get no picture on the
external monitor. Also, if I use system-config-display to try to activate dual
screen it correctly identifies the external monitor but does not display
anything. Instead the resolution on my built in monitor changes to the
resolution of the external monitor. The only way to fix this problem is to
remove the cable between the external monitor and the computer. Then the
resolution of the built in monitor returns to normal.

Version-Release number of selected component (if applicable):
xorg-x11-drv-nv-2.1.5-2.fc8.src.rpm

How reproducible:
Always

Steps to Reproduce:
1. Plug in external monitor.
2. Get no picture on external monitor.
3. Try to fix things with system-config-display and bork your settings.
  
Actual results:
No picture.

Expected results:
Picture.

Additional info:
Comment 1 Matěj Cepl 2007-12-20 17:25:29 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Andreas Tunek 2007-12-21 06:39:00 EST
Created attachment 290228 [details]
xorg.cong with cable plugged in.
Comment 3 Andreas Tunek 2007-12-21 06:40:07 EST
Created attachment 290229 [details]
Log 1
Comment 4 Andreas Tunek 2007-12-21 06:41:10 EST
Created attachment 290230 [details]
log 2
Comment 5 Andreas Tunek 2007-12-21 06:41:59 EST
Created attachment 290231 [details]
Don't really know what this is....
Comment 6 Andreas Tunek 2008-03-28 01:25:24 EDT
I have tried this on the F9 beta and I get the same results. Do you want the
same files again?
Comment 7 Matěj Cepl 2008-03-28 13:00:46 EDT
Actually, yes please -- F9 beta was totally rewritten, so things are different
(albeit still broken for you :().
Comment 8 Andreas Tunek 2008-03-30 12:10:14 EDT
Created attachment 299631 [details]
xorg.conf + log
Comment 9 Andreas Tunek 2008-04-18 06:41:42 EDT
Still broken in the latest rawhide...
Comment 10 Bug Zapper 2008-05-14 00:13:22 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Dave Airlie 2008-06-04 07:58:46 EDT
-nv doesnt support dualhead on this card and never will...

You could try nouveau.. the F10 package might work good.
Comment 12 Andreas Tunek 2008-06-04 13:59:03 EDT
Is that nouveau for Fedora 10 you mean?
Comment 13 Matěj Cepl 2008-06-05 08:33:16 EDT
There is nouveau in Fedora since at least Fedora 8. xorg-x11-drv-nouveau

Note You need to log in before you can comment on or make changes to this bug.