Bug 426418 - IBM ServeRaid Fc8 x86_64 issues several ips ...Reset Request Cache Flushed.. at boot
IBM ServeRaid Fc8 x86_64 issues several ips ...Reset Request Cache Flushed.. ...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-20 16:37 EST by Lorenzo Fiorini
Modified: 2009-01-09 00:34 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 00:34:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lorenzo Fiorini 2007-12-20 16:37:34 EST
Description of problem:

I've installed Fc8 x86_64 on an IBM x236 dual Xeon 4GB ServeRaid 7k that has
worked for years with Fc5. At boot it hangs for minutes after the nash and
before the udev. Adding debug to the kernel parameter I saw that ips issues
several msg like "ips xxxxxx Reset Request Cache Flushed" waiting for 10 secs
between every message. After that the server starts and seems to work as
expected. Before x86_64 I tried Fc8 x86 ( 32 bit ) and Ubuntu Amd64 without the
problem. I've updated ServeRaid's Bios to the latest 7.12.13 but the issue remains.

Version-Release number of selected component (if applicable):

kernel 2.6.23.9-85.fc8
ServeRaid Bios 7.12.13

How reproducible:

At every restart

Steps to Reproduce:

1. Power on the server
2. Wait
3.
  
Actual results:

Boot the server takes minutes

Expected results:

Normal boot times

Additional info:
Comment 1 Chuck Ebbert 2007-12-21 16:20:24 EST
The adapter is being reset over and over at startup. Hard to say if it is an
error causing reset or someone calling the reset ioctl.
Comment 2 Lorenzo Fiorini 2008-02-01 11:16:24 EST
(In reply to comment #1)
> The adapter is being reset over and over at startup. Hard to say if it is an
> error causing reset or someone calling the reset ioctl.

It seems that ips in 2.6.24 has a related fix:

from ChangeLog.ips

IBM ServeRAID driver Change Log
2	~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
3	
4	        5.00.01  - Sarasota ( 5i ) adapters must always be scanned first  
5	                 - Get rid on IOCTL_NEW_COMMAND code  
6	                 - Add Extended DCDB Commands for Tape Support in 5I         
        
7	        
8	        4.90.11  - Don't actually RESET unless it's physically required
9	                 - Remove unused compile options
[...]
Comment 3 Lorenzo Fiorini 2008-02-21 09:53:59 EST
kernel 2.6.25-0.61.rc2.git4.fc9 from koji fixes the problem.
Comment 4 Bug Zapper 2008-11-26 04:06:10 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Bug Zapper 2009-01-09 00:34:28 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.