Bug 426419 - yumdownloader does not support "--disablerepo" option
yumdownloader does not support "--disablerepo" option
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-utils (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-20 16:41 EST by Nico Kadel-Garcia
Modified: 2008-06-17 11:48 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2008-0388
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:21:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nico Kadel-Garcia 2007-12-20 16:41:11 EST
Description of problem:

The yumdownloader tool is a handy way to pre-download both older and newer 
versions of software. But occasionally, a local repo and the RHEL repos will 
have duplicate versions of the same file. The "yum downloadonly" command is 
fine for this, but it requires root privileges and requires considerable 
finessing to grab only a package, not the dependencies.

yumdownloader works fine, *except* that because it cannot obey the --
disablerepo command, you cannot forbid any of the listed repos. And with yum-
rhn-plugin in place, as the root user, you cannot even move aside the .repo 
files to disable them!

Matching this feature of yumdownloader to match that of yum itself would thus 
be quite useful.

Version-Release number of selected component (if applicable):
1.0.4

How reproducible:

Type "yumdownloader --disablerepo=rhel-i386-server-vt-5 kernel" or use any 
valid repo for your distribution.


Steps to Reproduce:
1.
2.
3.
  
Actual results:
Application fails.


Expected results:
Download the current kernel from other, valid repositories.

Additional info:
Comment 1 James Antill 2007-12-20 16:56:23 EST
 This'll get fixed when we rev. yum-utils.

 Atm. you can use the yum-downloadonly plugin to do the same thing.
Comment 2 Nico Kadel-Garcia 2007-12-21 02:45:59 EST
Thanks. The yum-downloadonly plugin is really, really not as effective for the 
reasons I mentioned: it requires root privilege. The yum command itself also 
uses lock files, so you can't download an RPM for review while any other 
process is using the yum command.

Given the noticeably poor response times of the RHN network and updates from 
where I am in the UK, I'd really like to be able to grab just the one package 
or the few packages I need to look at, especially if it's from a non-RHN 
repository. And I'd like to do it while the system is doing whatever other yum 
operations it needs. This poor response time, and the engineering to build 
local repos to work around it, actually interfere with RHEL sales and encourage 
the use of CentOS, which has vastly faster update times. I'm using 
yumdownloader to build a local RHEL mirror to build Xen systems and the "mock" 
chroot cages for building new software, neither of which gracefully use yum-rhn-
plugin without other odd work.
Comment 3 James Antill 2007-12-21 09:24:42 EST
 So I assume you don't know about reposync?
 And as I said I'll fix yumdownloader in the next yum-utils rev. ... which will
be ASAP.
Comment 4 Nico Kadel-Garcia 2007-12-22 03:37:34 EST
I'll look at reposync, thank you for the pointer.
Comment 5 Nico Kadel-Garcia 2007-12-25 12:54:34 EST
reposync is obviously a superior way to do the mirroring: I approve of it.

I think one big reason I missed it is the lack of a man page, and the confusion 
of other mirroring tools in the world cluttering documentation searches. What 
would it take to get man pages written for it and the other utilities? If I 
write them based on the format of hte other yum-utils man pages, could we get 
them in?
Comment 6 James Antill 2007-12-27 09:05:00 EST
 Sure, if you write them I'll make sure they get in, you can post them here. To
me or to the yum-utils mailing list: yum-devel@linux.duke.edu
Comment 7 James Antill 2008-01-14 10:01:19 EST
 This is basically a free fix, due to the upgrade for RHEL-5.2
Comment 8 RHEL Product and Program Management 2008-01-14 10:05:49 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 9 Jan Hutař 2008-01-14 13:29:58 EST
qa_ack+
Comment 13 errata-xmlrpc 2008-05-21 10:21:48 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0388.html
Comment 14 Chris Ward 2008-06-17 11:48:43 EDT
Reminder: This bug includes the 'RHTS' QA Whiteboard Keyword. Don't forget to add
'RHTSdone' to the QA Whiteboard along with a comment describing where the RHTS
test can be found once the RHTS test has been written. Otherwise, if an RHTS
will not be created, please remove RHTS from the qa whiteboard.

Note You need to log in before you can comment on or make changes to this bug.