Bug 426423 - mkinitrd and/or nash does not cope with valid mount options resulting in failed boots
mkinitrd and/or nash does not cope with valid mount options resulting in fail...
Status: CLOSED DUPLICATE of bug 296361
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-20 17:20 EST by Michal Jaegermann
Modified: 2007-12-21 00:54 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-21 00:54:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2007-12-20 17:20:39 EST
Description of problem:

There could be excellent reasons to mount file systems with
'relatime' options.  After /etc/fstab edits and restarting
the system everything looks just fine.
$ mount | grep relatime
/dev/sda3 on / type ext3 (rw,relatime)
..... (and so on as it was supposed to be).

The catch is that after a kernel update a system does not boot.
The culprit is mkinitrd which is producing in 'init' script
on a boot image a command like that:

mkrootdev -t ext3 -o relatime,ro LABEL=/

and 'mkrootdev' from nash fails on this.  Simply ignoring options
which it does not understand looks like the simplest solution here.

The above can be worked around using an undocumented option
'--rootopts=defaults' to mkinitrd when generating a replacement
boot image.  Unfortunately kernel package scripts are not doing
that.  Another possibility is to hack /sbin/mkinitrd and force
it to always use "defaults" and not bother with /etc/fstab.
Trivial but prone to overwrite on updates.  The best likely
would be to fix nash.

Are there really any good reasons to pass options to mkrootdev?

Version-Release number of selected component (if applicable):
mkinitrd-6.0.19-4.fc8

How reproducible:
always
Comment 1 Warren Togami 2007-12-21 00:54:48 EST
https://bugzilla.redhat.com/show_bug.cgi?id=296361#c4
According to this, relatime is now the default, so you don't really need
relatime support in nash.  Bug #296361 remains open though because it is
probably a good idea to fix nash anyway for safety's sake.

*** This bug has been marked as a duplicate of 296361 ***

Note You need to log in before you can comment on or make changes to this bug.