Bug 426424 - firstboot doesn't work in locale sv_SE.UTF-8
firstboot doesn't work in locale sv_SE.UTF-8
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-20 17:28 EST by Dennis Björklund
Modified: 2008-01-02 15:34 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-02 15:34:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Björklund 2007-12-20 17:28:18 EST
firstboot did not show up after a fresh install of F8.

When I tried to run it by hand I got the traceback below. When I tried that
command again using LANG=C it worked but it doesn't work in the swedish locale
(sv_SE.UTF-8) that is the default for this system.


# firstboot --reconfig
starting reconfig mode
no image found
  File "/usr/sbin/firstboot", line 101, in <module>
    firstbootWindow(fb)
  File "/usr/share/firstboot/firstbootWindow.py", line 150, in __init__
    self.loadModules()
  File "/usr/share/firstboot/firstbootWindow.py", line 426, in loadModules
    loaded = imputil.imp.load_module(module, found[0], found[1], found[2])
  File "/usr/share/firstboot/modules/smolt.py", line 22, in <module>
    t = gettext.translation('smolt', '/usr/share/locale', fallback = True)
  File "/usr/lib/python2.5/gettext.py", line 480, in translation
    t = _translations.setdefault(key, class_(open(mofile, 'rb')))
  File "/usr/lib/python2.5/gettext.py", line 180, in __init__
    self._parse(fp)
  File "/usr/lib/python2.5/gettext.py", line 316, in _parse
    plural = v[1].split('plural=')[1]
Comment 1 Chris Lumens 2008-01-02 15:34:12 EST
This is because the Swedish translation file does not include a definition for
plural forms, and Python doesn't like that much.  This will be fixed in the next
build of firstboot and in an update release should I make one.

Note You need to log in before you can comment on or make changes to this bug.