This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 426447 - TB3e8fa63e yumRepo.py:765:_getRepoXML:RepoError: Cannot retrieve repository metadata (repomd.xml)for repository: fedora. Please verify its path and try again
TB3e8fa63e yumRepo.py:765:_getRepoXML:RepoError: Cannot retrieve repository m...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-kickstart (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
http://www.geocities.jp/aataca_jp/
:
: 426991 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-20 22:06 EST by Taka
Modified: 2008-01-02 15:25 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-02 15:25:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Taka 2007-12-20 22:06:54 EST
Description of problem:
[Sorry for my 'Not-Smart' report:
I'm not familiar with the manner of the Formal (Bugzilla) Error Report.
'Cause this is the first time for me to report to you; redhat.

 I found the "Exception" window telling to "save and report the crush-dump to
system-config-kickstart @ https://bugzilla.redhat.com/bugzilla"
 when I "1st-start"ed the "System-kickstart" under running OOo(Debugging macro),
Kate, Konqueror, ksysguard, kwikdisk.

 So, I've decided to report and reached this page.
Everything is new to me, 
I might make mistakes in the "manner of report"
 if I force myself to fit all of your "High" way (in the level)
 = the elegant way.
Forgive me to report the Minimum-Information in my way.
]

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:vvvvv Following's the Crush-dump vvvvvv 
Component: system-config-kickstart
Summary: TB3e8fa63e yumRepo.py:765:_getRepoXML:RepoError: Cannot retrieve
repository metadata (repomd.xml) for repository: fedora. Please verify its path
and try again

Traceback (most recent call last):
  File "/usr/bin/system-config-kickstart", line 81, in <module>
    kickstartGui.kickstartGui(file)
  File "/usr/share/system-config-kickstart/kickstartGui.py", line 167, in __init__
    self.packages_class = packages.Packages(xml, self.ksHandler)
  File "/usr/share/system-config-kickstart/packages.py", line 179, in __init__
    self.y = sckYumBase(pbar)
  File "/usr/share/system-config-kickstart/packages.py", line 122, in __init__
    self.doTsSetup()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 63, in doTsSetup
    return self._getTs()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 77, in _getTs
    self._tsInfo.setDatabases(self.rpmdb, self.pkgSack)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 526, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 381, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 242, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 142, in populate
    if self._check_db_version(repo, mydbtype):
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 199, in
_check_db_version
    if repo.repoXML.repoData.has_key(mdtype):
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 769, in <lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 765, in _getRepoXML
    raise Errors.RepoError, msg
RepoError: Cannot retrieve repository metadata (repomd.xml) for repository:
fedora. Please verify its path and try again

Local variables in innermost frame:
msg: Cannot retrieve repository metadata (repomd.xml) for repository: fedora.
Please verify its path and try again
self: fedora
e: Cannot find a valid baseurl for repo: fedora
Comment 1 Chris Lumens 2007-12-30 19:59:29 EST
*** Bug 426991 has been marked as a duplicate of this bug. ***
Comment 2 Chris Lumens 2008-01-02 15:25:40 EST
This traceback will be replaced by an error dialog in the next build of
system-config-kickstart, though I am curious as to what is going on with your
repo configs that would be causing this problem.

Note You need to log in before you can comment on or make changes to this bug.