Bug 426461 - ACPI events ceased to trigger suspend
ACPI events ceased to trigger suspend
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-21 04:11 EST by Julian Sikorski
Modified: 2007-12-21 04:42 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-21 04:42:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julian Sikorski 2007-12-21 04:11:23 EST
Description of problem:
The recent update to the kernel made some Fn keys on Toshiba Satellite A100
working again, but apparently at a cost of not going to suspend on ACPI events:

[jsikorski@snowball ~]$ lshal -m

Start monitoring devicelist:
-------------------------------------------------
10:03:47.233: computer_logicaldev_input_2 property button.state.value = true
10:03:47.234: computer_logicaldev_input_2 condition ButtonPressed = lid
10:04:10.898: computer_logicaldev_input_2 property button.state.value = false
10:04:10.899: computer_logicaldev_input_2 condition ButtonPressed = lid
10:04:17.780: platform_i8042_i8042_KBD_port_logicaldev_input condition
ButtonPressed = sleep

None of the above suspend the laptop. With the kernel 2.6.23.8-63.fc8, the Fn
keys on Toshiba Satellite A100 did not work, so it was only possible to suspend
with the lid, not with Fn-F3.

Version-Release number of selected component (if applicable):
2.6.23.9-85.fc8

How reproducible:
always

Steps to Reproduce:
1. Grab a Toshiba Satellite A100 laptop
2. Install nvidia blob if necessary
3. Close the lid
  
Actual results:
LCD goes blank

Expected results:
Laptop suspends

Additional info:
Feel free to ask if you need more information.
Comment 1 Julian Sikorski 2007-12-21 04:42:39 EST
Looks like g-p-m config got busted somehow. Sorry for the noise.

Note You need to log in before you can comment on or make changes to this bug.