This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 426463 - On login, dialogue keeps asking for password on behalf of Evolution
On login, dialogue keeps asking for password on behalf of Evolution
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-keyring (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-21 04:38 EST by Bill Case
Modified: 2015-03-03 17:31 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 00:34:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Case 2007-12-21 04:38:46 EST
Description of problem:
On login, gnome-keyring-manager, Seahorse and gnome-keyring can't open my
passwords for Evolution ( I have tried the two frontends and from the command line)

Version-Release number of selected component (if applicable):
Came with F8_x64, Gnome 2.20.2

How reproducible:
Every time I login

Steps to Reproduce:
1. login
2.
3.
  
Actual results:
I get a dialogue asking for my password; I enter it (the same as my login
password).  It then asks me for my email account passwords.  If I just cancel
the requests it continues to open Evolution and update my mail anyways.

Expected results:
I expect to login with no password requests.

Additional info:
I have tried all the fixes e.g. fixing /etc/pam.d/gdm, by adding
'auth optional pam_keyring.so try_first_pass'
'session optional pam_keyring.so',
and deleting ~/gnome2/keyrings etc.  Nothing works.
Comment 1 Bill Case 2007-12-26 13:48:43 EST
Two additional problems;
1) a second user on my machine cannot access the keyring at all for evolution;
both Seahorse and gnome-keyring-manager will not accept a new password.  (This
happens when two users are loggedin through the 'user switcher'.  I will log out
now or user1 and see what happens when I login directly as user2.)
2) a partial list of user1's saved 'other collected keys' shows up in user2's
Seahorse frontend when using 'user switcher'
Comment 2 Bill Case 2007-12-26 14:17:12 EST
Same thing happens as above when user2 is logged in directly.
Comment 3 Bill Case 2008-03-11 11:25:09 EDT
After reading comments on the Fedora Users list by others that they had now
gotten their login (gdm) to work by removing ~/gnome2/keyrings I tried it again
-- hoping some of the upgrades had included a fix.  No joy.

I renamed my ~/gnome2/keyrings; logged out and in; entered my user password in
the keyring dialogue and my email accounts passwords. Now, whenever I login I
still have to enter my user password in the dialogue; however, there is no new
requests for my email passwords, so I suppose that is progress.

I have no new or strange F8 configurations and this Evolution password
registration should work without further notice.
Comment 4 jharitos 2008-03-13 01:36:51 EDT
I'm having the same problem as well with Network Manager asking me for the
password every time on boot to "unlock the keyring". I've added the same lines
to the gdm and I've deleted all keyrings then rebooted all without success.
Comment 5 Devrim GUNDUZ 2008-06-02 01:35:26 EDT
I can reproduce the same behaviour on Fedora-9. After upgrading from Fedora 8 to
Fedora 9 (it was a fresh install, but I did not format my /home partition),
Evolution does not remember any of my password, and keeps asking pass everytime. 
Comment 6 GJahchan 2008-09-24 22:39:04 EDT
Had similar messages in /var/log/messages and no matter what I did could not log in to Exchange server with evolution/exchange connector on a fresh FC9 installation.

Applying the workaround documented at: http://forums.fedoraforum.org/forum/showthread.php?t=172827 seems to have solved the Exchange login problem. However the: 'gnome-keyring-daemon[4782]: couldn't read 4 bytes from client:' messages continue filling up the messages file.
Comment 7 Bug Zapper 2008-11-26 04:06:23 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bug Zapper 2009-01-09 00:34:34 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.