Bug 426465 - Root recieves error mail every 15 min. re: bugzilla
Root recieves error mail every 15 min. re: bugzilla
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: bugzilla (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: John Berninger
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-21 04:56 EST by Bill Case
Modified: 2008-04-16 23:57 EDT (History)
2 users (show)

See Also:
Fixed In Version: 3.0.2-6.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-16 23:52:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Case 2007-12-21 04:56:20 EST
Description of problem:
root mail reports the following:

Date: Thu, 20 Dec 2007 10:30:04 -0500
From: Cron Daemon <root@localhost.localdomain>
To: apache@localhost.localdomain
Subject: Cron <apache@CASE> cd /usr/share/bugzilla && env LANG=C
        /usr/share/bugzilla/whine.pl
Auto-Submitted: auto-generated
X-Cron-Env: <SHELL=/bin/sh>
X-Cron-Env: <HOME=/var/www>
X-Cron-Env: <PATH=/usr/bin:/bin>
X-Cron-Env: <LOGNAME=apache>
X-Cron-Env: <USER=apache>

Can't connect to the database.
Error: Can't connect to local MySQL server through socket
+'/var/lib/mysql/mysql.sock' (2)
  Is your database installed and up and running?
  Do you have the correct username and password selected in localconfig?

Version-Release number of selected component (if applicable):
mySQL ver 14.12

How reproducible:
self reproducing -- every 15 min sends me (root) a mailing

Steps to Reproduce:
1. none
2.
3.
  
Actual results:


Expected results:


Additional info:

mysqld is installed and running.
I have the correct username and password selected in /etc/bugzilla/localconfig.

mySQL Administrator returns the following error:

Could not connect to host 'CASE'.
MySQL Error Nr. 2003
Can't connect to MySQL server on 'CASE' (111)
[CASE is the name of my machine or localhost]

I did a fresh install of F8, replacing F7 except for /home.
I never had this error on F7.  I have tried everything I can think of.
Comment 1 Tom Lane 2007-12-21 09:26:10 EST
Sure sounds to me like you haven't started mysqld.
Comment 2 Bill Case 2007-12-23 10:23:05 EST
My mysqld was running.  What happened was this:

With the fresh F8 install, I mistakenly included the Bugzilla program.
Bugzilla requires an extensive setup according to its README and
documents, including adding a mySQL database. It is something
worth doing, but not until later when I am prepared to climb into the
whole issue. 

For now I just uninstalled (yum erase Bugzilla) and the error issues
went away. It took me some time to find the problem.

As an aside (perhaps defensively), shouldn't the Bugzilla program self-install
with at least all the default settings working including its database?
Comment 3 Tom Lane 2007-12-23 15:12:58 EST
Hmm, so you're saying that you did nothing except install the bugzilla package, and it took it upon itself 
to start a daemon process (or at least install a cron job)?  That violates all sorts of packaging rules: the 
mere presence of an RPM on a machine shouldn't cause anything to happen.  Reassigning bug to 
appropriate component.
Comment 4 Bill Case 2007-12-23 15:57:49 EST
The last response makes me feel very stupid or a liar, so I re-checked.

I downloaded F8_x64 on Dec 10; installed on Sat. Dec 16, at which time I picked
Bugzilla out of the various packages to install.  I spent Sunday re-setting up
my system including starting httpd and mysqld services.  Sunday night I looked
at my root mail for the first time and the Bugzilla messages (about 10 messages)
were there.  I tweaked and played with my system most of Monday erronously
assuming that the messages were about sending some error to Bugzilla; not that
Bugzilla was the problem.

I don't remember at anytime during that period doing anything specific with
Bugzilla.  I was concentrating on restoring my system to the setup I had in F7,
not activating any new unfamiliar programs.  There was nothing in my ~/home
directory related to Bugzilla that I know of.  F8 was the first time I have
downloaded it. (I have double checked my copy of the F7 rpm file).

If it didn't "take it upon itself to start a daemon process (or at least install
a cron job)", something is still wrong, because I didn't do it intentionally.
Comment 5 John Berninger 2007-12-23 16:33:49 EST
In response to comment 3 - the fact that the bugzila package installs a script
in /etc/cron.daily (thus creating a cron job) is not a violation of packaging
rules - it's a behavior that several other packages demonstrate (webalizer,
logrotate, tmpwatch, and prelink, to name only four).  The cron job uses the
bugzil configuration to send 'whine' emails every 15 minutes - an incorrectly
configured, or unconfigured in this case, system will result in those cron jobs
failing, sending the root emails noticed.  

the root cause of the emails was the fact that the bugzilla package had been
installed but not yet properly configured for the target environment.  In
relation to comment 2, the database cannot be set up by the install script since
that would disallow user configuration of the database target.
Comment 6 Bill Case 2007-12-23 17:43:10 EST
I understand that this Bugzilla issue is now CLOSED as NOTABUG.  I am not
disagreeing. However, I had asked on the Fedora Users Mailing List (and
elsewhere) for help and could get no useful answer before filing this bug.  I
spent several hours trying to figure out where the root emails were coming from
and what they were telling me in a meaningful way.  

May I suggest that the wording of these emails be changed a little to something
that clearly indicates "You have installed Bugzilla but not yet configured it."
or some such.  How that might be done, I have no idea.  But, it would have saved
me a lot of time and the time of others who tried to help me.

The End.
Regards Bill
Comment 7 Tom Lane 2007-12-23 17:52:57 EST
In fact, the problem here is exactly that bugzilla is trying to do something when it hasn't yet been 
configured to run correctly.  As a general rule packages should not try to start services merely because 
they've been installed --- there are a small number of exceptions but bugzilla surely is not one of them.  I 
have made this same mistake myself in the past --- take a look at bug #127552.

There doesn't currently seem to be anything in the Fedora packaging guidelines discouraging such 
practice, but I am pretty certain that the policy hasn't changed since it was explained to me.  I will go forth 
and find out what it takes to get an explicit statement that this is bad practice.  In the meantime I suggest 
you reconsider your position that this is NOTABUG.
Comment 8 Jeremy Katz 2007-12-28 09:12:59 EST
Yeah, this is pretty poor form for a package to do on initial install -- an
automated whine mail that "you haven't set me up" when the web service requires
some manual configuration before it will actually run is poor form.  It'd be
like if every service dropped in a cron job to send mail if they weren't running
when they weren't initially turned on.
Comment 9 John Berninger 2007-12-29 08:51:20 EST
OK, I've been convinced.  Not completely, but enough to push an update to
testing.  Not sure why Koji hasn't made it's usual comment in here, but 3.0.2-6
is in testing for F-7, F-8, and devel.
Comment 10 Fedora Update System 2008-01-02 20:31:54 EST
bugzilla-3.0.2-6.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bugzilla'
Comment 11 Fedora Update System 2008-01-02 20:33:39 EST
bugzilla-3.0.2-6.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bugzilla'
Comment 12 Fedora Update System 2008-04-16 23:52:14 EDT
bugzilla-3.0.2-6.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2008-04-16 23:57:13 EDT
bugzilla-3.0.2-6.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.