Bug 426491 - Installer attempted to run, loads for several seconds, then crashes.
Installer attempted to run, loads for several seconds, then crashes.
Status: CLOSED DUPLICATE of bug 421961
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-12-21 10:33 EST by Daniel Clarke
Modified: 2007-12-26 13:52 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-12-26 13:52:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Daniel Clarke 2007-12-21 10:33:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20071128 Fedora/ Firefox/

Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Click "Applications" drawer in taskbar
2.Click "Add/Remove Software"
3. ???

Actual Results:
Pirut loads for an abnormally long time, then closes and brings up a bug report.

Expected Results:
Pirut should have loaded for a short while, then presented the user with all installed packages, and available packages that may be installed.

Additional info:
Component: pirut
Summary: TBaa979ac4 priorities.py:88:exclude_hook:AttributeError: 'NoneType' object has no attribute 'samearch'

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 483, in <module>
  File "/usr/sbin/pirut", line 479, in main
  File "/usr/sbin/pirut", line 407, in run
  File "/usr/sbin/pirut", line 423, in doRefresh
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 339, in doRefreshRepos
    self.reposSetup(pbar, thisrepo)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 303, in reposSetup
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 72, in doTsSetup
    return self._getTs()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 85, in _getTs
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 91, in _getTsInfo
    self._tsInfo.setDatabases(self.rpmdb, self.pkgSack)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 529, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 396, in _getSacks
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 169, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/priorities.py", line 88, in exclude_hook
    if opts.samearch:
AttributeError: 'NoneType' object has no attribute 'samearch'

Local variables in innermost frame:
conduit: <yum.plugins.MainPluginConduit instance at 0x98d2c8c>
commands: None
opts: None
Comment 1 Jeremy Katz 2007-12-26 13:52:01 EST

*** This bug has been marked as a duplicate of 421961 ***

Note You need to log in before you can comment on or make changes to this bug.