Bug 426492 - Review Request: jabbin - Instant messaging and VoIP Jabber client
Review Request: jabbin - Instant messaging and VoIP Jabber client
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-21 10:33 EST by Krzysztof Kurzawski
Modified: 2008-02-11 02:31 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-11 02:31:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mtasaka: fedora‑review+
kevin: fedora‑cvs+


Attachments (Terms of Use)
Patch to use external qca (qca-devel needed) (802 bytes, patch)
2008-02-04 11:59 EST, Mamoru TASAKA
no flags Details | Diff
PATCH: fix compilation with gcc4.3 (4.63 KB, patch)
2008-02-09 10:50 EST, Hans de Goede
no flags Details | Diff
Patch to honor Fedora cflags correctly (947 bytes, patch)
2008-02-10 09:04 EST, Mamoru TASAKA
no flags Details | Diff

  None (edit)
Description Krzysztof Kurzawski 2007-12-21 10:33:55 EST
Spec URL: http://kurzawa.nonlogic.org/rpm/jabbin/jabbin.spec
SRPM URL: http://kurzawa.nonlogic.org/rpm/jabbin/jabbin-2.0-1.beta2a.fc8.src.rpm
Description: Jabbin is a Instant messaging and VoIP Jabber client.

P.S I'm looking for sponsor.
Comment 1 Mamoru TASAKA 2007-12-27 02:28:56 EST
I will check this later.
Comment 2 Mamoru TASAKA 2007-12-27 09:54:40 EST
Well, before checking this package fully:

- This package contains 3rdparty/ directory and uses the libraries
  under the directory
3party/jrtplib
3party/libjingle
3party/qca
   However, all these libraries are already in Fedora. Please apply
   patches against jabbin so that jabbin uses not the internal 3rd
   parties' libraries but the external system-wide libraries provided
   as Fedora rpms.

- And please fix the versioning.
  Ref: the subsection "Pre-Release packages" of
  http://fedoraproject.org/wiki/Packaging/NamingGuidelines
Comment 3 Krzysztof Kurzawski 2007-12-28 08:30:48 EST
Spec URL: http://kurzawa.nonlogic.org/rpm/jabbin/jabbin.spec
SRPM URL: http://kurzawa.nonlogic.org/rpm/jabbin/jabbin-2.0-0.2.beta2a.fc8.src.rpm

I fixed version, but I have problem with 3rd parties libraries. I tried to make
patch, but the libjingle in Jabbin is quite diffrent than libjingle in Fedora
repository is quite different. Libjingle in Fedora hasn't got class
PhoneSessionClient and I don't know what should I do.
Comment 4 Mamoru TASAKA 2007-12-28 12:22:34 EST
Well, I tried to check libjingle-0.3.11-5.fc9 and actually
all header files under talk/session/phone are marked as
noninst_headers (if libjingle does not support mediastreamer).

So: please follow below.
- You can use libjingle 0.3.11 tarball, unpack it and replace
  the directory jabbin-2.0beta2a/3party/libjingle/ to use header
  files missing from libjingle-devel rpm.
- However anyway jabbin should not use libjingle.a but should link
  against libjingle.so in libjingle rpm.
Comment 5 Krzysztof Kurzawski 2007-12-29 13:50:07 EST
I have got problem. I tried to make a patch which was changing paths to
libjingle, qca and jrtplib, but the libingle in Jabbin is quite diffrent than
libjingle in Fedora repository and I couldn't build RPM. You said than I should
use tarball with libjingle, but I don't know how should this patch look like?
What should I do?

Here is the link to this patch which I tried to make:
http://kurzawa.nonlogic.org/rpm/jabbin/jabbin-pathfix.patch
Comment 6 Mamoru TASAKA 2007-12-31 03:38:48 EST
Please make srpm anyway and attach the build.log so that
we can check what you are actually trying to do and where build fails
easily.
Comment 7 Krzysztof Kurzawski 2008-01-02 12:26:37 EST
http://kurzawa.nonlogic.org/rpm/jabbin/build.log

But I used here this patch above. I don't use any tarball here, because I don't
knoow how should it look like.
Comment 8 Mamoru TASAKA 2008-01-07 10:20:49 EST
Urm.. I quickly tried to use external libjingle but it seems
rather difficult...

So for now would you use internal libjingle and rewrite (reupload)
the new srpm?
Comment 9 Krzysztof Kurzawski 2008-01-15 17:00:04 EST
Sorry, but I have got problem with my Fedora and I will try to repair this for a
few days.
Comment 10 Xavier Lamien 2008-01-17 11:52:48 EST
Removed NEED-SPONSOR block, i'll sponsor him.
Comment 11 Krzysztof Kurzawski 2008-01-26 14:23:40 EST
Ok so I tried to build jabbin with internal libjingle but qca and jrtplib from
fedora repository. I made patch:
http://kurzawa.nonlogic.org/rpm/jabbin/jabbin-pathfix2.patch

I tried to build but I had an error.
http://kurzawa.nonlogic.org/logs/jabbin-build.log

I think the jrtplib in fedora repository is quite different than jrtplib from
jabbin.

What should I do?
Comment 12 Mamoru TASAKA 2008-01-29 11:54:29 EST
Well, actually I could not find jabbintransmitter.h in
Fedora jrtplib 3.7.1 and I guess jabbin is using (very?) old
jrtplib... For now it seems we should use internal jrtplib, too.
Comment 13 Krzysztof Kurzawski 2008-01-29 16:14:31 EST
I made patch to use qca from fedora repository:
http://kurzawa.nonlogic.org/rpm/jabbin/jabbin-pathfix3.patch

And I tried to build RPM with this patch, but I have got:
http://kurzawa.nonlogic.org/logs/jabbin-build2.log

What should I do?
Comment 14 Mamoru TASAKA 2008-01-30 12:34:38 EST
Would you retry, please?
Comment 15 Krzysztof Kurzawski 2008-01-30 13:43:16 EST
What should I retry?
Comment 16 Mamoru TASAKA 2008-02-04 11:59:47 EST
Created attachment 293909 [details]
Patch to use external qca (qca-devel needed)

Well, the attached patch should work to use external
qca (qca-devel needed). However
- Currently Fedora specific compilation flags are not
  honored
- This package fails to build on dist-f9 (rawhide). Rawhide
  now uses g++43 and jabbin compilation fails with g++43
  on many points...
Comment 17 Mamoru TASAKA 2008-02-04 12:01:27 EST
dist-f8-updates-candidate build with the patch in comment 16
applied is here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=394937
Comment 19 Mamoru TASAKA 2008-02-05 07:31:54 EST
As I said in comment 16:
- This jabbin doesn't build on g++43 (i.e. rawhide)
  http://koji.fedoraproject.org/koji/taskinfo?taskID=396315

  I tried to fix this, however apparently it requires not a few
  fixes. I hope I have some time to try on this weekend, however
  I suggest that you ping to upstream.

- Builds on dist-f8-updates-candidate, however Fedora specific
  compilation flags are not honored correctly. More patches or
  some sed trick or so is needed.
Comment 20 Hans de Goede 2008-02-09 10:50:18 EST
Created attachment 294471 [details]
PATCH: fix compilation with gcc4.3

Mamoru Tasaka asked me to take a look at fixing the gcc-4.3 compilation errors
seen in F-9. This patches fixes them.
Comment 21 Krzysztof Kurzawski 2008-02-10 04:25:56 EST
Fixed
Spec URL: http://kurzawa.nonlogic.org/rpm/jabbin/jabbin.spec
SRPM URL: http://kurzawa.nonlogic.org/rpm/jabbin/jabbin-2.0-4.beta2a.fc8.src.rpm

Thanks for patch!
Comment 22 Mamoru TASAKA 2008-02-10 09:04:09 EST
Created attachment 294496 [details]
Patch to honor Fedora cflags correctly

Thank you to Hans for fixing gcc43 related issues!

For 2.0-0.4:

* License
-----------------------------------------------------
src/tools/openpgp/gpgproc/	Dual of QPL and GPLv2 (strict)
-----------------------------------------------------
  - License tag must be GPLv2 (strict).

* Compiler flags
  - Fedora specific compilation flags are not honored correctly.
    http://koji.fedoraproject.org/koji/taskinfo?taskID=411301

    The proposal patch attached fixes this issue.
    http://koji.fedoraproject.org/koji/taskinfo?taskID=411576

* Timestamps
  - When using "cp" or "install" commands, please use "-p" option
    to keep timestamps on installed files.
------------------------------------------------------
install -m 644 certs/readme certs/rootcert.xml
$RPM_BUILD_ROOT%{_datadir}/%{name}/certs
------------------------------------------------------

Please fix the 3 issues above before committing into CVS.
Other things are okay.

------------------------------------------------------
     This package (jabbin) is APPROVED by me
------------------------------------------------------
Comment 24 Krzysztof Kurzawski 2008-02-10 09:20:40 EST
New Package CVS Request
=======================
Package Name: jabbin
Short Description: Instant messaging and VoIP Jabber client
Owners: kurzawa
Branches: F-7 F-8
InitialCC:
Cvsextras Commits: yes
Comment 25 Mamoru TASAKA 2008-02-10 09:25:26 EST
Oops.. The string "strict" is not needed in the spec file, sorry.
Comment 26 Kevin Fenzi 2008-02-10 15:18:39 EST
cvs done.
Comment 28 Krzysztof Kurzawski 2008-02-11 02:31:37 EST
Imported and built. Thanks again for review!

Note You need to log in before you can comment on or make changes to this bug.