Bug 426518 - wifi card does'nt get ip adresse at boot
wifi card does'nt get ip adresse at boot
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i686 Linux
low Severity high
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-21 13:54 EST by Mehdi Bahri
Modified: 2008-03-10 09:53 EDT (History)
2 users (show)

See Also:
Fixed In Version: kernel-2.6.24.3-12.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 09:53:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
content of dmesg (30.45 KB, text/plain)
2008-02-23 14:15 EST, Mehdi Bahri
no flags Details
lsmod result (3.45 KB, text/plain)
2008-02-23 14:16 EST, Mehdi Bahri
no flags Details
that's for lspci -n (717 bytes, text/plain)
2008-02-23 14:17 EST, Mehdi Bahri
no flags Details
Here is the content of /var/log/messages (1.26 MB, text/plain)
2008-02-23 14:25 EST, Mehdi Bahri
no flags Details

  None (edit)
Description Mehdi Bahri 2007-12-21 13:54:27 EST
Description of problem:

After last kernel update (2.6.23.9-85.fc8) wifi is blocked at boot, it just
gives a time out error and no ip adress is assignated but when system booted,
using service network restart wifi works fine so problem is just related to boot
time.

Version-Release number of selected component (if applicable):

2.14.1.5-2 with kernel 2.6.23.9-85.fc8

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthias Saou 2008-02-03 06:59:42 EST
Reassigning to the kernel since I doubt this is firmware package related...
Comment 2 John W. Linville 2008-02-04 10:20:38 EST
Please attach the contents of /var/log/messages, as well as the output 
of 'dmesg', 'lsmod', and 'lspci -n'.  Does updating to the latest available F8 
kernel change the situation?
Comment 3 Mehdi Bahri 2008-02-23 14:15:19 EST
Created attachment 295713 [details]
content of dmesg
Comment 4 Mehdi Bahri 2008-02-23 14:16:36 EST
Created attachment 295714 [details]
lsmod result
Comment 5 Mehdi Bahri 2008-02-23 14:17:30 EST
Created attachment 295715 [details]
that's for lspci -n
Comment 6 Mehdi Bahri 2008-02-23 14:20:17 EST
I'm sorry things have changed since I posted this bug but situation is the same
here are some infos I've collected, hope it can help :

Even with NetworkManager the connexion doesn't always work but iwl is loaded and
mac80211.
Unloading and reloading iwl3945 sometimes makes the connexion work.

I've recently re-installed the system, with the original kernel it works
perfectly but after update everything's broken so I too think the bug is related
to kernel.

dmesg, lsmod and lspci -n results in attachment.
Comment 7 Mehdi Bahri 2008-02-23 14:25:05 EST
Created attachment 295717 [details]
Here is the content of /var/log/messages
Comment 8 John W. Linville 2008-03-05 15:13:15 EST
It looks like you are associating successfully, but then you are getting 
unencrypted frames when you are expecting encryption.  One might expect this 
behavior if the WEP key is set but the AP is not using encryption.

Please try executing the following command (as root):

   iwconfig wlan0 key off

Does that change the situation for you?  Also, please try the latest available 
F8 kernel:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=41351

Please post your results here...thanks!
Comment 9 Mehdi Bahri 2008-03-08 11:40:23 EST
Hello

Since I've update to kernel 2.6.24.3-12 the problem seems to be solved. Wifi 
works well with NetworkManager and WPA PSK encryption, also it connects at 
session oppening. I hope it will continue.

thank you for your great work on the fedora kernel.

Bye

Note You need to log in before you can comment on or make changes to this bug.