Bug 426520 - This version of ISC DHCP is based on the release available on ftp.isc.org.
This version of ISC DHCP is based on the release available on ftp.isc.org.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-21 14:11 EST by Peter Aganyo
Modified: 2014-03-16 23:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 00:34:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ifcfg-eth0, ifcfg-eth0:1, ifcfg-eth0:2 (787 bytes, text/plain)
2007-12-21 14:11 EST, Peter Aganyo
no flags Details

  None (edit)
Description Peter Aganyo 2007-12-21 14:11:08 EST
I have five aliases for eth0 and when I run the command: 

service network restart

I get the following message:

[root@penguin ~]# service network restart
Shutting down interface eth0:                              [  OK  ]
Shutting down loopback interface:                          [  OK  ]
Bringing up loopback interface:                            [  OK  ]
Bringing up interface eth0:  
Determining IP information for eth0...dhclient(23988) is already running - exiting. 
This version of ISC DHCP is based on the release available
on ftp.isc.org.  Features have been added and other changes
have been made to the base software release in order to make
it work better with this distribution.
Please report for this software via the Red Hat Bugzilla site:
    http://bugzilla.redhat.com
exiting.
 failed.
                                                           [FAILED]
[root@penguin ~]# 

-------------------

The reason for running the command is because I want the aliases to start also.
When the computer boots up only the parent eth0 starts, the aliases are all
inactive.

I will attach configuration for eth0 and eth0:1 and eth0:2

When I use the GUI to start the aliases manually it works but no other way works.
Comment 1 Peter Aganyo 2007-12-21 14:11:08 EST
Created attachment 290255 [details]
ifcfg-eth0, ifcfg-eth0:1, ifcfg-eth0:2
Comment 2 Bill Nottingham 2007-12-21 14:40:47 EST
> The reason for running the command is because I want the aliases to start also.

Then set 'ONPARENT=yes'; that should accomplish this.
Comment 3 Peter Aganyo 2007-12-21 17:18:10 EST
Thanks Bill. Sorry, I should have said that I had already tried that option and 
it did not work either.
Comment 4 Bill Nottingham 2007-12-21 17:31:52 EST
Interesting - the aliases aren't brought up at all?
Comment 5 Peter Aganyo 2007-12-24 19:11:02 EST
Quite interesting!! They are not brought up at all. I usually have to use the 
settings I attached originally and then once I reboot and the parent device 
comes up, I use the GUI Network Configuration tool to bring up the aliases. And 
since I do not know yet how to do this from the command line, I cannot do it 
while logged through SSH - from another machine.
Comment 6 Bug Zapper 2008-11-26 04:06:56 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Bug Zapper 2009-01-09 00:34:54 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 8 Himanshu Thakur 2010-01-01 21:13:49 EST
I can reproduce this bug in Fedora 12. 

its giving error when i try to start my network service.

Reopen Bug !

Note You need to log in before you can comment on or make changes to this bug.