Bug 426544 - Can't use pull packages using yum
Can't use pull packages using yum
Status: CLOSED DUPLICATE of bug 378911
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-rhn-plugin (Show other bugs)
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Justin Sherrill
Depends On:
  Show dependency treegraph
Reported: 2007-12-21 16:56 EST by Asa Douglass
Modified: 2007-12-21 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-12-21 17:07:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Asa Douglass 2007-12-21 16:56:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20070718 Red Hat/ Firefox/

Description of problem:
I am able to initially register this computer with redhat using the "software updater" but after that I can't pull packages with yum or re-start the software updater. When I try either it gives me the same stack trace:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Run Software Updater or yum
2. voila!

Actual Results:
It crashed

Expected Results:
I should have pulled info from redhat

Additional info:
Component: Software Manager
Summary: TBfb95fe59 rhnplugin.py:303:_noExceptionWrappingGet:UnboundLocalError: local variable 'result' referenced before assignment

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 453, in ?
  File "/usr/sbin/pirut", line 449, in main
  File "/usr/sbin/pirut", line 358, in run
  File "/usr/sbin/pirut", line 373, in doRefresh
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 146, in reposSetup
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 299, in doRepoSetup
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 503, in setup
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 530, in _loadRepoXML
    cache=self.http_caching == 'all')
  File "/usr/lib/yum-plugins/rhnplugin.py", line 209, in _getFile
    start, end, copy_local, checkfunc, text, reget, cache)
  File "/usr/lib/yum-plugins/rhnplugin.py", line 303, in _noExceptionWrappingGet
    return result
UnboundLocalError: local variable 'result' referenced before assignment

Local variables in innermost frame:
remote: https://xmlrpc.rhn.redhat.com/XMLRPC/GET-REQ/rhel-x86_64-server-5/repodata/repomd.xml
start: None
url: None
text: rhel-x86_64-server-5
self: rhel-x86_64-server-5
cache: False
reget: None
server: https://xmlrpc.rhn.redhat.com/XMLRPC/GET-REQ/rhel-x86_64-server-5
relative: repodata/repomd.xml
headers: (('X-RHN-Auth-Expire-Offset', '3600.0'), ('X-RHN-Auth-User-Id', ''), ('X-RHN-Auth', 'qJ6uTE2ldiPgMr+AlE/QWA=='), ('X-RHN-Auth-Server-Time', '1198273445.87'), ('X-RHN-Server-Id', 1009202644), ('Pragma', 'no-cache'))
checkfunc: (<bound method RhnRepo._checkRepoXML of <rhnplugin.RhnRepo object at 0xff6e910>>, (), {})
copy_local: 1
end: None
local: //var/cache/yum/rhel-x86_64-server-5/repomd.xml
Comment 1 Justin Sherrill 2007-12-21 17:07:49 EST

*** This bug has been marked as a duplicate of 378911 ***

Note You need to log in before you can comment on or make changes to this bug.