Bug 426549 - Printing broken
Printing broken
Status: CLOSED DUPLICATE of bug 424331
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-21 17:28 EST by Need Real Name
Modified: 2008-01-02 09:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-02 09:09:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2007-12-21 17:28:57 EST
I can no longer print anything! I'm not sure where to start. This worked a few
weeks ago..

There seems to no longer be a /etc/init.d/hplip script..

hplip-2.7.7-6.fc8
hpijs-2.7.7-6.fc8

With queued print job and printer turned off, I turn on the printer again..

Dec 21 23:26:54 box kernel: usb 3-2: new full speed USB device using ohci_hcd
and address 5
Dec 21 23:26:54 box kernel: usb 3-2: configuration #1 chosen from 1 choice
Dec 21 23:26:54 box kernel: usblp0: USB Bidirectional printer dev 5 if 1 alt 0
proto 2 vid 0x03F0 pid 0x4811
Dec 21 23:26:54 box kernel: scsi4 : SCSI emulation for USB Mass Storage devices
Dec 21 23:26:57 box python: hp-probe[4306]: warning: No devices found on the
'usb' bus. If this isn't the result you are expecting,
Dec 21 23:26:57 box python: hp-probe[4306]: warning: check to make sure your
devices are properly connected and powered on.
Dec 21 23:26:58 box python: hp-probe[4308]: warning: No devices found on the
'usb' bus. If this isn't the result you are expecting,
Dec 21 23:26:58 box python: hp-probe[4308]: warning: check to make sure your
devices are properly connected and powered on.
Dec 21 23:26:59 box kernel: scsi 4:0:0:0: Direct-Access     HP       PSC 1610  
      1.00 PQ: 0 ANSI: 2
Dec 21 23:26:59 box kernel: sd 4:0:0:0: [sdb] Attached SCSI removable disk
Dec 21 23:26:59 box kernel: sd 4:0:0:0: Attached scsi generic sg2 type 0
Dec 21 23:27:08 box PSC_1600_series?serial=XXX: io/hpmud/musb.c 549: invalid
product id string: Operation not permitted
Dec 21 23:27:08 box PSC_1600_series?serial=XXX: io/hpmud/musb.c 1003: unable to
open hp:/usb/PSC_1600_series?serial=XXX
Dec 21 23:27:08 box PSC_1600_series?serial=XXX: INFO: open device failed; will
retry in 30 seconds...
Dec 21 23:27:08 box PSC_1600_series?serial=XXX: io/hpmud/musb.c 549: invalid
product id string: Operation not permitted
Dec 21 23:27:08 box PSC_1600_series?serial=XXX: io/hpmud/musb.c 1003: unable to
open hp:/usb/PSC_1600_series?serial=XXX
Dec 21 23:27:08 box PSC_1600_series?serial=XXX: INFO: open device failed; will
retry in 30 seconds...
Comment 1 Wayne Whitney 2007-12-24 15:00:24 EST
I am having the same problem, and it is kernel dependent.  Using
kernel-2.6.23.8-63.fc8.x86_64, everything works fine.  Using kernel
kernel-2.6.23.9-85.fc8.x86_64, nothing prints, and the following error message
shows up in /var/log/messages:

hpijs: io/hpmud/musb.c 549: invalid product id string: Operation not permitted

I have an HP OfficeJet K-80 connected via USB to an x86_64 system.  Hope this helps.
Comment 2 Need Real Name 2007-12-30 12:11:33 EST
Not being able to print is a show stopper for me. Upping severity.
Comment 3 Nathaniel Daw 2008-01-01 12:44:18 EST
I am getting the same problem with x86/32 -- I think this is a permissions issue
on the USB device. Getfacl shows that there is a permissions mask on the device
preventing writing. Compare the below with the example at

http://cyberelk.net/tim/2007/10/04/hplip-device-permissions-with-consolekit/

and you will see (I think) that write should not be masked out. I dont know
where this comes from though.

$ getfacl /dev/bus/usb/002/004
getfacl: Removing leading '/' from absolute path names
# file: 004
# owner: root
# group: lp
user::rw-
user:[logged in console user]:rw-               #effective:r--
group::rw-                      #effective:r--
mask::r--
other::r--
Comment 4 Tim Waugh 2008-01-02 09:09:38 EST

*** This bug has been marked as a duplicate of 424331 ***

Note You need to log in before you can comment on or make changes to this bug.