Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 426556 - Claws create a new directory in /home/user when importing theme
Claws create a new directory in /home/user when importing theme
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: claws-mail (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-21 19:43 EST by Thomas Canniot
Modified: 2007-12-28 04:24 EST (History)
0 users

See Also:
Fixed In Version: 3.2.0-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-28 04:24:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Canniot 2007-12-21 19:43:49 EST
Description of problem:
Claws-mail creates a new directory when I imported a theme into it trough the menu :

/home/mrtom/home/mrtom/.claws-mail/themes/TangoClaws-0.3/

having the theme normaly inside /home/mrtom/.claws-mail/themes/TangoClaws-0.3/
does not work.

Packages installed :

claws-mail-plugins-smime-3.1.0-1.fc8
claws-mail-plugins-bogofilter-3.1.0-4.fc8
claws-mail-3.1.0-4.fc8
claws-mail-plugins-pgp-3.1.0-4.fc8

Just go to http://www.claws-mail.org/themes.php?section=downloads and install a
new theme, it will create this strange tree :)
Comment 1 Andreas Bierfert 2007-12-22 02:36:23 EST
Well to quote from this same page:
"Installation
Untar the package.
Start Claws Mail.
Go to /Configuration/Preferences.../Display/Themes
Click the 'Install new' button and locate the theme directory.
Click 'OK'

Alternately they can be installed by root by untarring the package directly into
$PREFIX/share/claws-mail/themes/ They will then be available to every user. "

claws does exactly what it should. If you don't like this behavior please report
the bug with upstream in their bugzilla but from the package side of things
everything is working like it should.
Comment 2 Thomas Canniot 2007-12-23 15:06:27 EST
You did not understood me... claws creates a new /home/user directory INSIDE my
own home directory. Have a look at pwd :

[mrtom@annifrid TangoClaws-0.3]$ pwd
/home/mrtom/home/mrtom/.claws-mail/themes/TangoClaws-0.3


This IS the place where claws copies the untared theme when I chose it from the
claws gui... and I don't think having /home/mrtom/home/mrtom is a exactly what
it should do.
Comment 3 Andreas Bierfert 2007-12-23 19:18:37 EST
Well I cannot reproduce this:
/homes/awjb/.claws-mail/themes/TangoClaws-0.3

However is your normal config located in ~/.claws-mail? or do these things also
go into a separate directory?

What arch are you on?
Comment 4 Thomas Canniot 2007-12-24 04:22:08 EST
Yes my normal config  is in ~/.claws-mail but claws creates this new new
directory just for themes. There is nothing but themes inside this new directory.

I renamed my .claws-mail so as to start claws from the beginning and looked if
it was a real bug or not and even with a blank ~/.claws-mail it refers to the
/home/mrtom/home/mrtom/.claws-mail/themes/ for new themes.

I'm running i386.
Comment 5 Colin Leroy 2007-12-28 04:19:10 EST
It's fixed in 3.2.0:

2007-11-22 [wwp]	 3.1.0cvs19	
  * src/prefs_themes.c
    Yet another misuse of get_rc_dir(), still related
    to user themes. Completes 3.1.0cvs18.
View patchset
2007-11-22 [wwp]	3.1.0cvs18	
  * src/stock_pixmap.c
    Fix a misuse of get_rc_dir(), user themes dir was
    not set properly and some themes might have disappeared
    from themes list in prefs.
View patchset
Comment 6 Andreas Bierfert 2007-12-28 04:24:11 EST
Thanks for the response. As 3.2.0 is already pushed I will close this bug.

Note You need to log in before you can comment on or make changes to this bug.