Bug 426563 - nscd ignores entries in /etc/hosts
nscd ignores entries in /etc/hosts
Status: CLOSED DUPLICATE of bug 425768
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-22 01:49 EST by Valdis Kletnieks
Modified: 2007-12-22 01:55 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-22 01:55:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
typescript of nscd failure (1.08 KB, application/octet-stream)
2007-12-22 01:49 EST, Valdis Kletnieks
no flags Details

  None (edit)
Description Valdis Kletnieks 2007-12-22 01:49:45 EST
Description of problem:
If nscd is enabled, hosts listed in /etc/hosts aren't found - only DNS entries
are returned.  This is even *with* 'hosts = files, dns' listed in
/etc/nsswitch.conf (meaning that /etc/hosts should be consulted *first*).


Version-Release number of selected component (if applicable):
nscd-2.7.90-1


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
Programs like 'ping' get an NXDOMAIN response back.


Expected results:
Programs should be able to find hosts in /etc/hosts.

Additional info:
Filed under 'component=glibc' because there's no 'nscd' component listed in
enter_bug.cgi (even though it's a separate RPM)
Comment 1 Valdis Kletnieks 2007-12-22 01:49:45 EST
Created attachment 290285 [details]
typescript of nscd failure
Comment 2 Valdis Kletnieks 2007-12-22 01:55:03 EST
This looks like a dup of Bug #425768, closing it as such.  I didn't find it
before because I was trying to find nscd bugs, but that one is listed as a glibc
bug...

*** This bug has been marked as a duplicate of 425768 ***

Note You need to log in before you can comment on or make changes to this bug.