Bug 426573 - relatime no longer a mount option at boot
relatime no longer a mount option at boot
Status: CLOSED DUPLICATE of bug 296361
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-22 07:23 EST by Ben Boeckel
Modified: 2008-07-14 17:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-14 17:24:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Boeckel 2007-12-22 07:23:44 EST
Description of problem:
In my fstab, I have my local partitions (/ and a storage) set to mount with 
relatime. New releases of the kernel have since my currently running version 
(kernel-2.6.23.1-49.fc8) have failed to mount the partitions due to relatime 
no longer being recognized as a mount option. Has support for the option been 
dropped and if so, why?

Version-Release number of selected component (if applicable):
$ rpm -q kernel
kernel-2.6.23.1-49.fc8 // Works here (what I'm using now)
kernel-2.6.23.8-63.fc8 // Stopped working here
kernel-2.6.23.9-85.fc8 // Still doesn't work

How reproducible:
Always

Steps to Reproduce:
1. Have a partition mount with relatime in fstab.
2. Use new kernel
  
Actual results:
Fails to boot.

Expected results:
Boot

Additional info:
$ cat /etc/fstab
LABEL=/1        /       ext3    relatime        1       1
LABEL=/boot     /boot   ext3    noatime 1       0
tmpfs   /dev/shm        tmpfs   defaults        0       0
devpts  /dev/pts        devpts  gid=5,mode=620  0       0
sysfs   /sys    sysfs   defaults        0       0
proc    /proc   proc    defaults        0       0
LABEL=SWAP-sda2 swap    swap    defaults        0       0
LABEL=storage   /mnt/storage    ext3    relatime        0       0
Comment 1 Chuck Ebbert 2008-01-02 11:45:28 EST
relatime is now the default in Fedora.
Comment 2 Chuck Ebbert 2008-01-02 11:47:44 EST
This is a mkinitrd bug.
Comment 3 Ben Boeckel 2008-01-08 08:27:47 EST
I removed relatime from fstab and I still get the "relatime is not a valid 
mount option" message with the newest kernel. The interesting thing is that 
the kernel that works with it was then unable to mount / in read-write mode. I 
would guess that this means that after doing relatime, you can't go without 
(it's my guess at least).
Comment 4 Peter Jones 2008-07-14 17:24:50 EDT

*** This bug has been marked as a duplicate of 296361 ***

Note You need to log in before you can comment on or make changes to this bug.