Bug 426617 - Rhythmbox seek doesn't work with Fluendo MP3 decoder
Rhythmbox seek doesn't work with Fluendo MP3 decoder
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-12-22 19:38 EST by James Gregory
Modified: 2008-11-26 04:32 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-11-26 04:32:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description James Gregory 2007-12-22 19:38:21 EST
Description of problem:
When using the Fluendo MP3 decoder in Rhythmbox, it is not possible to use the
seek bar properly. Dragging it to seek in a song starts the song playing in the
correct place, but the seek bar then reverts back to the beginning, rather than
updating for the correct location in the song. This doesn't happen with an Ogg
Vorbis sound file.

Version-Release number of selected component (if applicable):
Rhythmbox 0.11.3, Fluendo MP3 decoder version unknown

How reproducible:

Steps to Reproduce:
1. Install the Fluendo MP3 decoder via Codec Buddy
2. Attempt to seek in an MP3 playing in Rhythmbox
Actual results:
Song seeks to the correct position, but the seek bar reverts to the start of the

Expected results:
The seek bar should match the location within the song.
Comment 1 Bastien Nocera 2008-01-17 12:11:04 EST
Any errors on the command-line? Could you also please make sure that you have
the latest version of the gstreamer plugins? (some are probably still in the
updates-testing repository)
Comment 2 James Gregory 2008-01-17 12:46:14 EST
Well, I have to confess that following my original post, I actually started
using the gstreamer-plugins-bad package from Livna as I knew that had worked.

I have just removed that package now to try Rhythmbox and it is failing to play
MP3s at all (even with updated gstreamer-plugins-base package). When I run it in
debug mode, then an error message about rb-player-gst-xfade.c appears, saying
that it isn't playing. Even when turning off the fader backend, Rhythmbox still
fails to play with lots of "tick" error messages
Comment 3 Bug Zapper 2008-11-26 04:08:06 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 

Note You need to log in before you can comment on or make changes to this bug.