Bug 42662 - Console programs don't understand window size when geometry resource used
Console programs don't understand window size when geometry resource used
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rxvt (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-29 04:46 EDT by Reuben Thomas
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-04 06:52:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
My .Xresources (19.32 KB, text/plain)
2001-05-29 06:18 EDT, Reuben Thomas
no flags Details
My .Xresources (19.32 KB, text/plain)
2001-05-29 06:18 EDT, Reuben Thomas
no flags Details

  None (edit)
Description Reuben Thomas 2001-05-29 04:46:22 EDT
Description of Problem:

When I start console programs such as jed and pine inside an rxvt when I have 
rxvt.geometry: 80x52 in my .Xresources, I get display glitches.

How Reproducible:

Every time

Steps to Reproduce:
1. Set rxvt.geometry: 80x52 in X environment
2. Start rxvt -e jed
3. The screen display is probably already corrupted (line asking to enter filename).

Actual Results:


Expected Results:


Additional Information:
 
If I start rxvt with an explicit -geometry, I don't get this problem. If I resize the 
window once started, things also work.
Comment 1 Harald Hoyer 2001-05-29 04:51:49 EDT
Works for me.... no problem.. 
$ rpm -q rxvt
rxvt-2.7.5-16
$ rpm -q jed
jed-0.99.12-1
Comment 2 Reuben Thomas 2001-05-29 05:19:54 EDT
I have rxvt-2.7.5-15, and according to up2date I'm up to date. This could be the
difference between us, perhaps?
Comment 3 Harald Hoyer 2001-05-29 05:47:35 EDT
no, tried it also with -15. How does the screen look like???
I have no problems... Which Windowmanager do you use?
Comment 4 Reuben Thomas 2001-05-29 05:57:38 EDT
The sort of thing that goes wrong is that text appears on the wrong line, e.g.
the penultimate line in jed (the status info) appears in the bottom line (the
minibuffer).

I'm using kwin, under KDE.
Comment 5 Harald Hoyer 2001-05-29 06:02:33 EDT
I also use kwin... I cannot reproduce your problem .. strange ..
Maybe you have strange .Xresources. you may attach the output of:
$ xrdb -query -all
Comment 6 Reuben Thomas 2001-05-29 06:18:32 EDT
Created attachment 19861 [details]
My .Xresources
Comment 7 Reuben Thomas 2001-05-29 06:19:16 EDT
I've attached my xrdb -query -all output, as you requested. HTH
Comment 8 Harald Hoyer 2001-05-29 09:05:12 EDT
maybe your ncurses is screwed.
$ rpm -qf /usr/share/terminfo/r/rxvt
ncurses-5.2-8
Comment 9 Reuben Thomas 2001-05-29 09:14:27 EDT
I have ncurses 5.2-8. My system is completely up-to-date according to up2date,
with the exception of cpp, since I've reverted to the egcs package from 6.2, to
avoid gcc-2.96 bugs.
Comment 10 Reuben Thomas 2001-05-31 05:10:04 EDT
I've since noticed that I sometimes get this problem even when rxvt is started
with -geometry 80x52.
Comment 11 Reuben Thomas 2001-06-04 06:52:04 EDT
I've discovered the problem: my screen was too small for 80x52; the maximum allowable 
is 80x50. But this still suggests there's a bug somewhere: perhaps kwin is not sending 
SIGWINCH to rxvt when it changes the size of the window on startup?
Comment 12 Harald Hoyer 2001-06-20 04:50:32 EDT
$ rpm -q rxvt kdebase
rxvt-2.7.6-2
kdebase-2.1.1-8

Note You need to log in before you can comment on or make changes to this bug.