Bug 426648 - wpa_supplicant starts later than network which breaks dhcp in encrypted wi-fi
wpa_supplicant starts later than network which breaks dhcp in encrypted wi-fi
Status: CLOSED DUPLICATE of bug 244029
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
8
All Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-23 12:30 EST by Peter Lemenkov
Modified: 2014-03-16 23:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-23 23:19:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Lemenkov 2007-12-23 12:30:16 EST
Description of problem:
If someone sets up his Fedora computer to get IP via dhcp in protected wireless
networks and his encrytion keys will be managed by wpa_supplicant (better choice
for a number of reasons), he won't be able to boot successfully because
wpa_supplicant starts after network

Version-Release number of selected component (if applicable):
initscripts-8.60-1

How reproducible:
always

Steps to Reproduce:
1. Just start pc in wi-fi-network with WPA and try to get IP via DHCP
  
Actual results:
Timeouts because there is no way to get IP.

Expected results:
IP received.

Additional info:
Take a look also at that similar bug (wpa_supplicant starts after messagebus):

https://bugzilla.redhat.com/show_bug.cgi?id=244029

Also, if we'll get wpa_supplicant to work this will close this bug:

https://bugzilla.redhat.com/show_bug.cgi?id=154348
Comment 1 Bill Nottingham 2007-12-23 23:19:53 EST

*** This bug has been marked as a duplicate of 244029 ***

Note You need to log in before you can comment on or make changes to this bug.