Bug 426649 - No pulseaudio-module-jack in F8
No pulseaudio-module-jack in F8
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-23 13:24 EST by Kevin Kofler
Modified: 2008-01-17 06:43 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.9.8-4.fc8.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-17 06:07:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Kofler 2007-12-23 13:24:16 EST
Description of problem:
There is no pulseaudio-module-jack in Fedora 8. This has been reenabled in 
Rawhide, but not F8. This is all the more annoying because JACK doesn't work 
with PA's ALSA plugin because JACK's ALSA backend requires mmap. As a result, 
there is no way to start JACK without suspending PA.

Version-Release number of selected component (if applicable):
pulseaudio-0.9.7-0.17.svn20071017.fc8
Comment 1 Kevin Kofler 2007-12-25 21:26:48 EST
Actually, _starting_ them both is not the problem, JACK has a "dummy" driver, 
but getting them to both actually output sound is.
Comment 2 Kevin Kofler 2008-01-17 06:43:30 EST
Getting JACK to output to PA is still a major PITA, but here's how to:
- in qjackctl, configure JACK for the dummy sound device and start it
- in pacmd, load-module module-jack-source
- in qjackctl, connect your JACK application to the PulseAudio JACK Source
- in a terminal, run: parec -d jack_in | pacat (Is there really no better way 
to echo a source to a sink in PA?)
- enjoy the half-second latency ;-)

Note You need to log in before you can comment on or make changes to this bug.