Bug 426651 - Window manager warning: Failed to read saved session file
Window manager warning: Failed to read saved session file
Status: CLOSED DUPLICATE of bug 471980
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-23 13:52 EST by Bruce Brackbill
Modified: 2014-06-18 05:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-18 00:29:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Window manager warning: Failed to read saved session file /home/janda/.config/metacity/sessions/10f262ea86e3f05ec6125065026953922400000018910023.ms: Failed to open file '/home/janda/.config/metacity/s (276.02 KB, text/plain)
2009-08-19 02:25 EDT, Janda
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 485751 None None None Never
GNOME Desktop 552387 None None None Never
Launchpad 150721 None None None Never

  None (edit)
Description Bruce Brackbill 2007-12-23 13:52:38 EST
Description of problem:
When booting up i get the error message:
SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/2197,unix/unix:/tmp/.ICE-unix/2197
Window manager warning: Failed to read saved session file
/home/bruce/.metacity/sessions/default1.ms: Failed to open file
'/home/bruce/.metacity/sessions/default1.ms': No such file or directory
13

(gnome-panel:2318): GLib-GObject-CRITICAL **: g_object_unref: assertion
`G_IS_OBJECT (object)' failed


Version-Release number of selected component (if applicable):

Distribution: Fedora release 8 (Werewolf)
Gnome Release: 2.20.2 2007-11-27 (Red Hat, Inc)
System: Linux 2.6.23.9-85.fc8 #1 SMP Fri Dec 7 15:49:59 EST 2007 i686
X Vendor: The X.Org Foundation
X Vendor Release: 10300000
Selinux: Enforcing
Accessibility: Disabled
GTK+ Theme: Nodoka
Icon Theme: Fedora

How reproducible:

Boot up and the error occurs
Comment 1 petrosyan 2008-11-05 13:32:00 EST
this bug is still present in Fedora rawhide.

Window manager warning: Failed to read saved session file /home/fedora/.config/metacity/sessions/108c8dbd2c642634de122590948877602100000015520008.ms: Failed to open file '/home/fedora/.config/metacity/sessions/108c8dbd2c642634de122590948877602100000015520008.ms': No such file or directory
Comment 2 Bug Zapper 2008-11-25 21:04:30 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Edward Kuns 2008-11-30 17:41:43 EST
I started seeing this after upgrading from Fedora 8 to Fedora 10.  At every login, my .xsession-errors file has the complaint:

Window manager warning: Failed to read saved session file /home/ekuns/.config/metacity/sessions/10ac181c8817043ef8122806581017838800000034350023.ms: Failed to open file '/home/ekuns/.config/metacity/sessions/10ac181c8817043ef8122806581017838800000034350023.ms': No such file or directory

Trying to manually save a session does not help.  (System -> Preferences -> Personal -> Sessions, go to Options tab, click "Remember Currently Running Application")  Doing this, running applications such as gnome-termainal are not restarted at my next login.

Note:  The directory ~/.config/metacity does not exist.

I did not have this problem under Fedora 8.
Comment 4 Edward Kuns 2008-12-01 20:07:20 EST
What additional information can I gather to get some movement on this bug?
Comment 5 Edward Kuns 2008-12-16 21:31:56 EST
Is anybody listening?  What information is needed?  It's really annoying to have to start all of my applications (such as gnome-terminal) each time I log in.  How can I help advance this bug?
Comment 6 Edward Kuns 2008-12-17 22:36:57 EST
Note:  I try to save my session by clicking on System -> Preferences -> Personal -> Session, then going to the options tab, then clicking on "Remember Currently Running Application" (sic), and I get the following complaint in .xsession-errors:

gnome-session-properties:7140): DEBUG: Session saving is not implemented yet!

Didn't this used to work?
Comment 7 Edward Kuns 2008-12-17 23:14:29 EST
With further searching, I found the following bug at gnome buzgilla.

http://bugzilla.gnome.org/show_bug.cgi?id=552387

and I have linked it above.  It looks like Gnome 2.24 was deliberately and knowingly released with this enormous regression.  I'm surprised that more people are not reporting this.
Comment 8 Edward Kuns 2008-12-17 23:29:25 EST
It looks like this should be marked redundant to Bug 471980.
Comment 9 Alex Lancaster 2008-12-18 00:29:52 EST
(In reply to comment #8)
> It looks like this should be marked redundant to Bug 471980.

Closing as per above.

*** This bug has been marked as a duplicate of bug 471980 ***
Comment 10 Janda 2009-08-19 02:25:39 EDT
Created attachment 357893 [details]
Window manager warning: Failed to read saved session file /home/janda/.config/metacity/sessions/10f262ea86e3f05ec6125065026953922400000018910023.ms: Failed to open file '/home/janda/.config/metacity/s

I am a newbie, I do not know how to describe the attachment.

Note You need to log in before you can comment on or make changes to this bug.