Bug 426663 - malfunctioning battery -> Starting HAL daemon [FAILED]
malfunctioning battery -> Starting HAL daemon [FAILED]
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-23 19:57 EST by Dean Brettle
Modified: 2013-03-05 22:54 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 00:36:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from hald --daemon=no --verbose=yes (333.63 KB, text/plain)
2007-12-23 19:57 EST, Dean Brettle
no flags Details

  None (edit)
Description Dean Brettle 2007-12-23 19:57:39 EST
Description of problem:

I have a Gateway MT6916 laptop.  It was working fine until I accidentally let
the battery run down.  After plugging it back in, it came back out of
hibernation but was acting a bit flaky (sorry I don't remember the details), so
I decided to do a cold reboot.  On boot, I got:

Starting HAL daemon: {pause for about 250 seconds} [FAILED]

As a result, NetworkManager couldn't find my wireless network, sound didn't
work, etc.

I tried changing SELinux to permissive mode and other suggestions I found
online, but nothing worked.

Eventually I checked my manual to see what the the red light on the front of the
machine meant and learned that my battery was "malfunctioning".  I powered-off
the machine, removed the battery, reinserted it, and it booted with no problem.

Conclusion: HAL does not handle a malfunctioning battery gracefully.

Version-Release number of selected component (if applicable):

hal-0.5.10-1.fc8


How reproducible:

Every time while the battery was malfunctioning.

Steps to Reproduce:
1.  Boot an MT6916 laptop with a malfunctioning battery.
  
Actual results:

Starting HAL daemon: {pause for about 250 seconds} [FAILED]
Network and sound don't work.

Expected results:

Starting HAL daemon: [OK]
Network and sound work.

Additional info:

At one point, I removed HAL from the startup sequence, and tried running:

hald --daemon=no --verbose=yes

I'll attach the output in case that helps.  There are a bunch of periodic
battery and AC adapter events at the end.
Comment 1 Dean Brettle 2007-12-23 19:57:39 EST
Created attachment 290318 [details]
Output from hald --daemon=no --verbose=yes
Comment 2 Bug Zapper 2008-11-26 04:08:50 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Bug Zapper 2009-01-09 00:36:08 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.