Bug 426681 - openoffice.org-2.3.0-6.7.fc8.src.rpm not builded
openoffice.org-2.3.0-6.7.fc8.src.rpm not builded
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
8
i686 Linux
low Severity low
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-24 02:45 EST by Danilo Marcucci
Modified: 2008-01-04 03:59 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-29 10:16:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
It's log from /usr/src/redhat/BUILD/OOG680_m6/instsetoo_native/unxlngi6.pro/OpenOffice/rpm/logging/en-US/ (288.50 KB, text/plain)
2007-12-24 02:45 EST, Danilo Marcucci
no flags Details

  None (edit)
Description Danilo Marcucci 2007-12-24 02:45:31 EST
Description of problem:
Not builded.

Version-Release number of selected component (if applicable):
openoffice.org-2.3.0-6.7.fc8.src.rpm

How reproducible:
rpmbuild --define "dist .fc8" --define "fedora 8" --rebuild --target i686
/usr/src/redhat/SRPMS/openoffice.org-2.3.0-6.7.fc8.src.rpm

Steps to Reproduce:
1.
2.
3.
  
Actual results:
**************************************************
ERROR: ERROR: Could not register all components!
in function: create_services_rdb
**************************************************

**************************************************
ERROR: Saved logfile:
/usr/src/redhat/BUILD/OOG680_m6/instsetoo_native/unxlngi6.pro/OpenOffice/rpm/logging/en-US/log_OOG680_en-US.log
**************************************************
... cleaning the output tree ...
... removing directory
/usr/src/redhat/BUILD/OOG680_m6/instsetoo_native/unxlngi6.pro/OpenOffice/rpm/zip/en-US
...
... removing directory
/usr/src/redhat/BUILD/OOG680_m6/instsetoo_native/unxlngi6.pro/OpenOffice/rpm/services.rdb/en-US_witherror_1
...
Sat Dec 22 09:17:57 2007 (02:25 min.)
dmake:  Error code 255, while making 'openoffice_en-US'
---* tg_merge.mk *---
+ echo - ---dump log start---
- ---dump log start---
+ cat '../unx*.pro/OpenOffice/rpm/logging/en-US/log_*__en-US.log'
cat: ../unx*.pro/OpenOffice/rpm/logging/en-US/log_*__en-US.log: No such file or
directory
errore: Stato d'uscita errato da /var/tmp/rpm-tmp.84937 (%install)


Expected results:
Builded

Additional info:
Comment 1 Danilo Marcucci 2007-12-24 02:45:31 EST
Created attachment 290345 [details]
It's log from /usr/src/redhat/BUILD/OOG680_m6/instsetoo_native/unxlngi6.pro/OpenOffice/rpm/logging/en-US/
Comment 2 Caolan McNamara 2007-12-29 10:16:59 EST
You probably have javac as icedtea and the configure is currently set to use
--with-jdk-home=/path/to/gcj meaning that some bits are getting built with
icedtea using the default java 1.6 bytecode output and then some bits are using
gij to try and run those and it can only handle up to java 1.5 bytecode. 

So you could probably should either try 
a) editing the .spec to toggle "jdk_is_gcj" to 0
b) or remove the icedtea-devel stuff to ensure that that ecj is used to built
the java bits

Not a bug I'd say, just a problem of supporting two java implementations at this
changeover time.
Comment 3 Danilo Marcucci 2008-01-04 03:59:01 EST
I have removed icedtea-devel (rpm -e java-1.7.0-icedtea-devel) and the package
openoffice.org-2.3.0-6.7.fc8.src.rpm its rebuild without error.
Thanks

Note You need to log in before you can comment on or make changes to this bug.