Bug 42669 - gcc crashes when compiling do_balan.c of Kernel-2.4.5
gcc crashes when compiling do_balan.c of Kernel-2.4.5
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-29 07:21 EDT by Michael Schnick
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-29 07:21:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schnick 2001-05-29 07:21:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.5 i686)

Description of problem:
I decided to compile a kernel on my own and got the kernel sources for
2.4.5. I left them unpatched and configured the kernel.

The current bug I want to report is the following:

gcc -D__KERNEL__ -I/usr/src/linux-2.4.5/include -Wall -Wstrict-prototypes
-O2 -fomit-frame-pointer -fno-strict-aliasing -pipe
-mpreferred-stack-boundary=2 -march=k6    -c -o do_balan.o do_balan.c
do_balan.c: In function `balance_leaf_when_delete':
do_balan.c:334: Internal error: Segmentation fault.

1. Reproduction shows another source file is producing errors as well:
gcc -D__KERNEL__ -I/usr/src/linux-2.4.5/include -Wall -Wstrict-prototypes
-O2 -fomit-frame-pointer -fno-strict-aliasing -pipe
-mpreferred-stack-boundary=2 -march=k6    -c -o tcp.o tcp.c
tcp.c: In function `tcp_destroy_sock':
tcp.c:1812: Internal error: Segmentation fault.


How reproducible:
Always

Steps to Reproduce:
1.make dep clean bZimage modules modules_install
2.
3.
	

Actual Results:  Each time the kernel compilation won4t finish, but it
looks like it4s a random file each time I call make

Expected Results:  kernel compilation should have completed

Additional info:

I had some strange experiences with kernel panics when i was copying large
files to or from the machine. The processes that made the kernel crash were
either ssh (from scp) or smbd.
I rechecked the integrity of gcc by downloading the apropriate rpm, and did
a rpm --verify gcc-2.96.81 && echo OK

I received an "OK" so I guess the compiler is still integer.
Comment 1 Jakub Jelinek 2001-05-29 07:28:55 EDT
If it is each time on a different file, then I'd suggest you replacing your
hardware. Compiler is a deterministic program, compiler faults are reproducible
at each invocation with the same options on the same input.

Note You need to log in before you can comment on or make changes to this bug.