Bug 426709 - Unhandled exception; TBaa979ac4 priorities.py:88:exclude_hook:AttributeError: 'NoneType' object has no attribute 'samearch'
Unhandled exception; TBaa979ac4 priorities.py:88:exclude_hook:AttributeError:...
Status: CLOSED DUPLICATE of bug 421961
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-24 13:50 EST by Kurt Albright
Modified: 2007-12-26 13:52 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-26 13:52:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Bug Report Log-File (1.63 KB, text/plain)
2007-12-25 06:42 EST, Benjamin Odenthal
no flags Details
PACKAGE MANAGER stop after a minutes with the same bug. (1.63 KB, application/octet-stream)
2007-12-26 09:42 EST, Mario Eric
no flags Details

  None (edit)
Description Kurt Albright 2007-12-24 13:50:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.10) Gecko/20071213 Fedora/2.0.0.10-3.fc8 Firefox/2.0.0.10

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1.  Run add/remove packages at any time.
2.
3.

Actual Results:
Got window with the following text:

"An unhandled exception has occurred.  This is most likely a bug.  Please save the crash dump and file a detailed bug report against pirut at https://bugzilla.redhat.com/bugzilla"

"Component: pirut
Summary: TBaa979ac4 priorities.py:88:exclude_hook:AttributeError: 'NoneType' object has no attribute 'samearch'

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 483, in <module>
    main()
  File "/usr/sbin/pirut", line 479, in main
    pm.run()
  File "/usr/sbin/pirut", line 407, in run
    self.doRefresh()
  File "/usr/sbin/pirut", line 423, in doRefresh
    self.doRefreshRepos(self._onlyrepo)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 339, in doRefreshRepos
    self.reposSetup(pbar, thisrepo)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 303, in reposSetup
    self.doTsSetup()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 72, in doTsSetup
    return self._getTs()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 85, in _getTs
    self._getTsInfo()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 91, in _getTsInfo
    self._tsInfo.setDatabases(self.rpmdb, self.pkgSack)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 529, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 396, in _getSacks
    self.plugins.run('exclude')
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 169, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/priorities.py", line 88, in exclude_hook
    if opts.samearch:
AttributeError: 'NoneType' object has no attribute 'samearch'

Local variables in innermost frame:
conduit: <yum.plugins.MainPluginConduit instance at 0x1117680>
commands: None
opts: None"

Expected Results:
Add/remove software should have run so I can install new software packages.

Additional info:
Comment 1 Daniel Wilcox 2007-12-24 14:03:03 EST
I have exactly the same bug; it's crippling because I want to be able to install
software.  My stack trace is exactly the same, except on the "conduit:" line,
where the number is 0x1113f80 instead.

Anyway, thanks to the Fedora people that have made such a good OS (ignoring this
bug).
Comment 2 Wilber Mahoney 2007-12-24 21:08:35 EST
Same except for conduit: <yum.plugins.MainPluginConduit instance at 0x909c34c>
Comment 3 Benjamin Odenthal 2007-12-25 06:42:07 EST
Created attachment 290375 [details]
Bug Report Log-File

This Error occur while Piriut was looking for Updates.
Comment 4 Thomas Law 2007-12-25 10:47:51 EST
I have the same error as well.
Comment 5 Kret 2007-12-25 12:38:22 EST
This same error. Yum is working, KYum is owrking, Yum Extender is working, but
pirut give this:

Component: pirut
Summary: TBaa979ac4 priorities.py:88:exclude_hook:AttributeError: 'NoneType'
object has no attribute 'samearch'

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 483, in <module>
    main()
  File "/usr/sbin/pirut", line 479, in main
    pm.run()
  File "/usr/sbin/pirut", line 407, in run
    self.doRefresh()
  File "/usr/sbin/pirut", line 423, in doRefresh
    self.doRefreshRepos(self._onlyrepo)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 339, in
doRefreshRepos
    self.reposSetup(pbar, thisrepo)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 303, in reposSetup
    self.doTsSetup()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 72, in doTsSetup
    return self._getTs()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 85, in _getTs
    self._getTsInfo()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 91, in _getTsInfo
    self._tsInfo.setDatabases(self.rpmdb, self.pkgSack)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 529, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 396, in _getSacks
    self.plugins.run('exclude')
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 169, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/priorities.py", line 88, in exclude_hook
    if opts.samearch:
AttributeError: 'NoneType' object has no attribute 'samearch'

Local variables in innermost frame:
conduit: <yum.plugins.MainPluginConduit instance at 0x9f1be4c>
commands: None
opts: None
Comment 6 Barry Eckert 2007-12-26 07:57:42 EST
Exact same bug except for address in conduit:
Local variables in innermost frame:
conduit: <yum.plugins.MainPluginConduit instance at 0x1116638>
commands: None
opts: None

I became aware of this because of a popup warning that the system was not
receiving updates, and that I should check my network connection or enable
software updates. All other package install/update utils working (yum, kyum,
synaptic, apt).
Comment 7 Jean-maurice Le Clech 2007-12-26 09:12:46 EST
Same error for me too except for the number of instance.
Yum seems to work fine from the command line.
Comment 8 Mario Eric 2007-12-26 09:42:32 EST
Created attachment 290408 [details]
PACKAGE MANAGER stop after a minutes with the same bug.
Comment 9 Antonio 2007-12-26 11:22:31 EST
Same problem & error with the number of instance as follow:
<yum.plugins.MainPluginConduit instance at 0x10ec368>
Comment 10 Jeremy Katz 2007-12-26 13:52:28 EST
The yum-priorities plugin is making assumptions about having a CLI parser
available which isn't the case when using pirut and friends.

*** This bug has been marked as a duplicate of 421961 ***

Note You need to log in before you can comment on or make changes to this bug.