Bug 426722 - encrypted fs patch breaks non-encrypted root-by-label
Summary: encrypted fs patch breaks non-encrypted root-by-label
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mkinitrd   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-12-25 01:34 UTC by Bill Nottingham
Modified: 2014-03-17 03:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-09 17:43:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Nottingham 2007-12-25 01:34:19 UTC
commit a6a0564dc8f0b4de10f01ec35fea3ccd75ffa849
Author: Peter Jones <pjones@redhat.com>
Date:   Thu Nov 29 14:25:19 2007 -0500

    Add support for luks-based encrypted filesystems

contains:

@@ -1081,7 +1090,7 @@ if [ "x$PROBE" == "xyes" ]; then
             "$rootdev" != "${rootdev##UUID=}" ]; then
         rootopts=$(echo $rootopts | sed -e 's/^r[ow],//' -e 's/,_netdev//' -e
's/_netdev//' -e 's/,r[ow],$//' -e 's/,r[ow],/,/' -e 's/^r[ow]$/defaults/' -e
's/$/,ro/')
         physdev=$(findblockdevinsys "$rootdev")
-        physdev=${physdev##*/}
+        physdev=${physdev##*/dev/}
         if [ -n "$physdev" ]; then
             vecho "Found root device $physdev for $rootdev"
         else

Since physdev at this point is returning /sys/block/sda/sda2, this doesn't prune
the device name at all, and it therefore fails to find the root FS driver.

Reverting this bit fixes it.

Comment 1 Peter Jones 2008-01-09 17:43:14 UTC
Should be fixed in 6.0.28-1.fc9 .


Note You need to log in before you can comment on or make changes to this bug.